summaryrefslogtreecommitdiff
path: root/dev-python/send2trash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/send2trash
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/send2trash')
-rw-r--r--dev-python/send2trash/Manifest3
-rw-r--r--dev-python/send2trash/metadata.xml12
-rw-r--r--dev-python/send2trash/send2trash-1.3.0.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/send2trash/Manifest b/dev-python/send2trash/Manifest
new file mode 100644
index 000000000000..19d6d569cf48
--- /dev/null
+++ b/dev-python/send2trash/Manifest
@@ -0,0 +1,3 @@
+DIST Send2Trash-1.3.0.tar.gz 5563 BLAKE2B 54fe34a5f984ded219a3c17f0e06b74a2e5624a8bda8d5723087a918217041bbf6a2b20976b0b4ba71d4a1e08d9ce645b8d5d7fb022ec8e5ed72786496e1ee90 SHA512 d308dd06ef7a11ad7bcb5d9195fb52aa0c0b8e76590ef11b1576d14815501c32c48b96167eb0a325e4f27d0dbf77f41c012a128d30c8f05d9d5ebec9967e21f3
+EBUILD send2trash-1.3.0.ebuild 619 BLAKE2B b9fdbfacbf69f7ad0437b173a3f53e20fa9679f8be6ac43d27f244b52d69feab928f1915edec1083f0cc1457b2ac9738e9e0875d8b0ca6b787daf2f07f699e1d SHA512 d4fbeb53d17bc10091d73f00566900afa438ebcfc301437dfa401a855fe389e06fc58d97ea7cad899b81372d8816294d33c0dfcfb210a275f2fe8a8fc5e1aa72
+MISC metadata.xml 381 BLAKE2B 5afbd1afb5fab636015e710ae55c2e7b6c9eb24d1ffe0418f4ae4c6d02befdf4d50922d25ae6dcd134e2f17de1cc5a7bcee0467cdfc03ac86cbf5b31d33153dd SHA512 309a92e88f854e9384519bb8a959025c97a8c75a7ee317a17d2c51c0a444b0fa008fd46fbbe07be3dd95ab2fc1930cfdf2a0c6df7ce68fc190610176f841067c
diff --git a/dev-python/send2trash/metadata.xml b/dev-python/send2trash/metadata.xml
new file mode 100644
index 000000000000..9dd529756191
--- /dev/null
+++ b/dev-python/send2trash/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Send2Trash</remote-id>
+ <remote-id type="github">hsoft/send2trash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/send2trash/send2trash-1.3.0.ebuild b/dev-python/send2trash/send2trash-1.3.0.ebuild
new file mode 100644
index 000000000000..8359172d151c
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+MY_PN="Send2Trash"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ http://hg.hardcoded.net/send2trash
+ https://pypi.org/project/Send2Trash/
+ https://github.com/hsoft/send2trash"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}