summaryrefslogtreecommitdiff
path: root/dev-python/selenium
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 21:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 21:23:22 +0100
commit15a738a098c486b6ec6d624050dd98826f9c2d3f (patch)
tree7b170748ee082c6db9b27bbc34b34b27e2e9873b /dev-python/selenium
parent3a2444aaf0bafd5c58c0dc8dda102352f20c76d8 (diff)
gentoo auto-resync : 29:09:2022 - 21:23:22
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.5.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index b002687de7cb..55523c1344b5 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,3 +1,5 @@
DIST selenium-4.4.3-py3-none-any.whl 985964 BLAKE2B b89c8d8c8a59c6fc8cc6aae84456e6e30f651148880f54bac84f4d82a2281d4ca1841e872fed80746c75fc795b8154c925386245f36940c9a54b1ac746d984dc SHA512 14142389a19cd311be229555b06c7dec5a11f852332775def10b6ffd956d07d0394f7af1463fc18116b0e4df055168158a5c2cc6794af760f16b6ae6ebb88aa4
+DIST selenium-4.5.0-py3-none-any.whl 995204 BLAKE2B 214050a4e410a4689255ec8472a1cb35a37596e73d46c48769aa8e184b6f84e281a20e7e5f812b8185edacfcbca6eed77507aa59ffcaeae384f962b4214928a0 SHA512 b22d80d750c85337a2b793799b5a63b11bed45d11b874c1a64c02f53b4adb57263e69bebc79203de3bdfa5b8708203959971723cf0aef7fb68bd1b2a9028e9d9
EBUILD selenium-4.4.3.ebuild 806 BLAKE2B f8b3b8f2d3e05441d427e0d7ca1b7ac48b31875bb2ff3e0f5db8d937c3c4114461894fa74441783fffc766ef4311fc24f6638b26165c6ada72922340260e4a52 SHA512 9ab7c3166881ccacf9a1b8f7fed9de64ae48068f734df7dbe894d5b02e82b48a018cf50be367ea028fe03c464ef8f78a1aa1d02807db788a18a3518920c5c895
+EBUILD selenium-4.5.0.ebuild 814 BLAKE2B 978b07161efd0127a6c0aec5dcbe5ab771fde8ddc10e006bdfd84bfddfdc50a6142e5afbd5aa1f27fb860f6917c8dbce99bf869779122231b53e82f3c223f673 SHA512 6a9c76a5cecec461d809c00ba2d9168aa6616c278f24cd9bb9aab5ab485f57261e2db5fa8fc8d471e093b6405a7131f15b7edebb2258e2df1c01e640e18849e8
MISC metadata.xml 383 BLAKE2B d437d1631cefdba12fe2c3ce38ddff34bf9dd2bbc777d5d3425556bda76865711c991c9e3a735130a1d55cb7c6578b083ecb473c28706a2d45563b31bdbe6d1b SHA512 c087323da996b9ad4d0bf8f00306cf044d5daab194b60af029cb1ce06bf60c660fd5959b7914e6f1103143c3e4533d293a6d3bd0ec1c95163eba09d8a19c13a1
diff --git a/dev-python/selenium/selenium-4.5.0.ebuild b/dev-python/selenium/selenium-4.5.0.ebuild
new file mode 100644
index 000000000000..5a7d0c13ff2d
--- /dev/null
+++ b/dev-python/selenium/selenium-4.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# GitHub releases don't include generated files, and on PyPi we do have them
+# but only in a wheel format.
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="https://www.seleniumhq.org"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${P::1}/${PN}/${P}-py3-none-any.whl
+"
+S=${WORKDIR}
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}