summaryrefslogtreecommitdiff
path: root/dev-python/securesystemslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-05 02:07:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-05 02:07:17 +0000
commita6764d56b1c85c8272783500983011c143c72d80 (patch)
tree4012d67c099814931c6188b22a6b5eb4e77f1d6a /dev-python/securesystemslib
parent38ecaf88ae0891dd2d7f2bdd9a7acdcd45835724 (diff)
gentoo auto-resync : 05:12:2024 - 02:07:17
Diffstat (limited to 'dev-python/securesystemslib')
-rw-r--r--dev-python/securesystemslib/Manifest2
-rw-r--r--dev-python/securesystemslib/securesystemslib-1.2.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/securesystemslib/Manifest b/dev-python/securesystemslib/Manifest
index 33cf53c21e83..8eed5f1b215d 100644
--- a/dev-python/securesystemslib/Manifest
+++ b/dev-python/securesystemslib/Manifest
@@ -1,3 +1,5 @@
DIST securesystemslib-1.1.0.tar.gz 934688 BLAKE2B f9e997306e0f17d5f75b8a85c732950460ff7443fd301e845c721a6e49f74dc48f6d2b5b7e0def63b262a09e6901affe8b293124bd4f82e69157e8cd26cb134c SHA512 65ec41c08ad679884c327c291e27a8529e6a559f52eb154a4c1c13a558df7845cabc21e466e908029afcd57b6581b2f429c4ea87e34b664e52369ca6b0f63ba1
+DIST securesystemslib-1.2.0.tar.gz 934472 BLAKE2B 573a8a422cb0b54f20caf35716c83051e70658e233a1334c983555aa26a9239ef86817fd80964bdd23e77408b403ee94b25e65359ccfa0aa54b854ed53d0e388 SHA512 eb1c0a3e2d304d26d1cf0f1a529810131a67a7f5bbed24233dd2495cea7b107beb7a0dd9ac85433b0526de0c39b346bbea5244b34b309e959ada5b9e7d272003
EBUILD securesystemslib-1.1.0.ebuild 885 BLAKE2B a1a74d4eeadbbbb3192e944c6db75ba1d9056a1d750c59295616357d840e74761352cbd9e0d2a39666616f7d8ee6c0cd76aad2555f9d894b21da41d1f5e460a3 SHA512 a3d1a6ac172213afe0bc0d38b230274ccbc1684091ff7b8050f71a118b86ce1281bf2bd33c0a247d671023b9d00ceff35b8c3e15dbe10cca5cf96021490c2073
+EBUILD securesystemslib-1.2.0.ebuild 857 BLAKE2B 97d11f33d2f2228109ee11ad974396f3a7f9fe0d9ce9747cd4f4297171444ce7e031e5ce872fc396f5c71cea991b08b200b473c75e8fd4fb100528c16a799d6d SHA512 0ea4ca9814f6abadbd72aba5d417adafc3b8253e2b16208b570a15e292e05457ed9915e6a0b89aab52c7c0b6b3ac6ed3aa9c52fda788ad9a00da308723084600
MISC metadata.xml 397 BLAKE2B 54aea8ac6c4200962e3cacf83933b1ced69ef9980348b58c92668c53b62ae6f918b13ca7320e08528272957a7b507b358b545e7a9f691c7f520ce829e21d9d9d SHA512 9dea6a3d95b8da1cceff9a5f3f8dc6f722fe0c29e9896deab11998c6849912e593021e9cd706a412d828bdc1bf83da2ec57d39a422dc86eb8ce738394525b683
diff --git a/dev-python/securesystemslib/securesystemslib-1.2.0.ebuild b/dev-python/securesystemslib/securesystemslib-1.2.0.ebuild
new file mode 100644
index 000000000000..2885b145a639
--- /dev/null
+++ b/dev-python/securesystemslib/securesystemslib-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cryptographic routines for Secure Systems Lab projects at NYU"
+HOMEPAGE="
+ https://github.com/secure-systems-lab/securesystemslib/
+ https://pypi.org/project/securesystemslib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/cryptography-40.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+# TODO: unbundle https://github.com/pyca/ed25519 (wtf? not on PyPI?)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyspx
+ tests/test_signer.py::TestSphincs::test_sphincs
+ )
+ local EPYTEST_IGNORE=(
+ # requires PyKCS11
+ tests/test_hsm_signer.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests
+}