summaryrefslogtreecommitdiff
path: root/dev-python/secretstorage/secretstorage-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/secretstorage/secretstorage-3.2.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/secretstorage/secretstorage-3.2.0.ebuild')
-rw-r--r--dev-python/secretstorage/secretstorage-3.2.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/secretstorage/secretstorage-3.2.0.ebuild b/dev-python/secretstorage/secretstorage-3.2.0.ebuild
deleted file mode 100644
index 4523aa493368..000000000000
--- a/dev-python/secretstorage/secretstorage-3.2.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-
-inherit distutils-r1
-
-MY_PN="SecretStorage"
-
-DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API."
-HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.org/project/SecretStorage/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( !hppa? ( !sparc? (
- gnome-base/gnome-keyring
- sys-apps/dbus
- ) ) )
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-src_test() {
- case ${ARCH} in
- hppa|sparc)
- einfo "gnome-keyring is not supported on ${ARCH}, skipping tests"
- return
- ;;
- esac
-
- distutils-r1_src_test
-}
-
-python_test() {
- dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
- || die "tests failed with ${EPYTHON}"
-}