summaryrefslogtreecommitdiff
path: root/dev-python/seaborn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-26 03:55:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-26 03:55:42 +0000
commit61044571b76d87a2eec42d36c9b7addf3e66e000 (patch)
tree5ac1c90c51a6331aabe26008ffb1150a72d7d2d0 /dev-python/seaborn
parentef596bcaa32d9c69d88a3451193cb242da803db1 (diff)
gentoo auto-resync : 26:02:2023 - 03:55:42
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/Manifest3
-rw-r--r--dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch19
-rw-r--r--dev-python/seaborn/seaborn-0.12.2.ebuild44
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index 21cd42ac5041..52956333da99 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1,3 +1,6 @@
+AUX seaborn-0.12.2-matplotlib-3.7.patch 753 BLAKE2B c4015d94eb336b8dadb29a1e56d3b1ba6e5f2134774b2bd99ed09a00025394adaa52093373578e27c4db08f28a62f4eac0a8b89b73dc7cdf818155c037b682ee SHA512 3dd36909ab7c933e4dbaee0f73a1b1e29b1b57057e59ade7fccadf4324b307c90578f018ce56b9a1294c067f367298819e4d397fdcb794f1e40cd2eb7b2057b1
DIST seaborn-0.12.0.tar.gz 1407601 BLAKE2B 3da8db0a0c08a40a3969a2ffce248f5521b4c7c93ecf0f014850093ef48331326454572ceea6ee1133805bf92540b0d2acecdfb7cb789d238f743b30e6a28947 SHA512 b2b06a22d48f19ace2448f465ca5e700f3486971d9fb86e85a1a8c9e2956b904e5f4c2c8075f848299b182cf8f69b2fac22366fedbd8012b9c44adc0bcb7e060
+DIST seaborn-0.12.2.tar.gz 1439798 BLAKE2B cf6903b1a2d27516bcafe46cabc81ea9fac80666394a6a82516630f9ac60afc7e9d31817e029cda9a08da04c0a37ce0244ad23acda16bca3283532ddb0fbdb71 SHA512 988a9922ee301b655911efa38905674b7dd15e7f7b157ad67f5befaeb02db492553f8bd6133b54d2dd7970b8dbbfd92d81d1faea3fa618247ebcaeb98620a060
EBUILD seaborn-0.12.0.ebuild 766 BLAKE2B 04950be78b6406e0d37cdb27b965be44d6e12d10f14271832bccc3fb8ec047fbda4ab641c22e296bcfb9498458afb3fb42c4413debffaca1f1aea98fbc7f5677 SHA512 a9b8be3f4f46cd07811e8e93c3f63a558c9c32d34af1d15c4953a2e0536b2cc0b2275519f3c979ae0e28a05cc9ae10ab2dbc4f5a665854c8033c8c033548da61
+EBUILD seaborn-0.12.2.ebuild 906 BLAKE2B 41e5ad03f0ef99a1e4960402e96c4507269ac7a9820b620bb4a35aa7ce216d554a6ee125174d9dbcbdcb5110ee5ff74ccbc3acad5c0161ac2d361609feb6f1d3 SHA512 887af46521d2f043385314ce95648bd1b1dca56ec62c9488624ab5672873a3c777362395fe838b5394fd80987901e902ddc240c078694229018742d87d55a069
MISC metadata.xml 1510 BLAKE2B 897785b5160185a2e2566495abb52d7a9136def9ea267601ea3719e0c5246c48ef09c4485674fa7c50202def865fe032df42a61396d95a097aafa82bfdeec05d SHA512 54374e04284143b80c0e97968ca9f31dc763ff4e14800a3ced4ed852722144cf89ebe5867b044597c8566a47d4e5e63359b7976bf6681cd4cf67aabcee7cf8a4
diff --git a/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch b/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch
new file mode 100644
index 000000000000..dbc4908321d9
--- /dev/null
+++ b/dev-python/seaborn/files/seaborn-0.12.2-matplotlib-3.7.patch
@@ -0,0 +1,19 @@
+https://github.com/mwaskom/seaborn/commit/db7ae11750fc2dfb695457239708448d54e9b8cd
+
+From db7ae11750fc2dfb695457239708448d54e9b8cd Mon Sep 17 00:00:00 2001
+From: Michael Waskom <mwaskom@users.noreply.github.com>
+Date: Wed, 25 Jan 2023 16:58:26 -0500
+Subject: [PATCH] Update test to reflect change in matplotlib 3.7 (#3236)
+
+--- a/tests/test_axisgrid.py
++++ b/tests/test_axisgrid.py
+@@ -331,7 +331,7 @@ def test_subplot_kws(self):
+ g = ag.FacetGrid(self.df, despine=False,
+ subplot_kws=dict(projection="polar"))
+ for ax in g.axes.flat:
+- assert "PolarAxesSubplot" in str(type(ax))
++ assert "PolarAxes" in ax.__class__.__name__
+
+ def test_gridspec_kws(self):
+ ratios = [3, 1, 2]
+
diff --git a/dev-python/seaborn/seaborn-0.12.2.ebuild b/dev-python/seaborn/seaborn-0.12.2.ebuild
new file mode 100644
index 000000000000..276eda23158c
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.12.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="https://seaborn.pydata.org https://github.com/mwaskom/seaborn"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-matplotlib-3.7.patch
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ cat > matplotlibrc <<- EOF || die
+ backend : Agg
+ EOF
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}