summaryrefslogtreecommitdiff
path: root/dev-python/sdnotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sdnotify
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sdnotify')
-rw-r--r--dev-python/sdnotify/Manifest5
-rw-r--r--dev-python/sdnotify/metadata.xml23
-rw-r--r--dev-python/sdnotify/sdnotify-0.3.1.ebuild22
-rw-r--r--dev-python/sdnotify/sdnotify-0.3.2.ebuild21
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/sdnotify/Manifest b/dev-python/sdnotify/Manifest
new file mode 100644
index 000000000000..39eedeb2894c
--- /dev/null
+++ b/dev-python/sdnotify/Manifest
@@ -0,0 +1,5 @@
+DIST sdnotify-0.3.1.tar.gz 2513 BLAKE2B cbce1d3c2bae3b3a02102cfea9ac104e7c2839b784a78309cfad0a66fc8b13bba66ae4bdb8dcf1d2171378e04f2c18e3697b22545a3e3f0593edff8adcc19dc3 SHA512 765e75e727ad5128269bfffd4d3f64666df654adc50965a54f3cd622933aca583faee5453f7fec3a23b6f754f4475522dd96a86ba643984cd72a575ec082709c
+DIST sdnotify-0.3.2.tar.gz 2459 BLAKE2B 1d1846e37889c36cfa7242d14e4040ebb9b73d3e53f5a3423447ae1a4912373e4249faa7803ac212e3c7d64371d1fe9e1be2d56f8604791cead2cbe22e422053 SHA512 f7e7d38c8d7f56ebad8b0343361a0bf6177208b94916430343a0a392015622d7bb62aa391e17956e5aa9a0d7189c79268cb86c46bb52b36488df5aebca5cfbd3
+EBUILD sdnotify-0.3.1.ebuild 530 BLAKE2B ff60e8c7d5af2b23403da57cd1ada1dac9eaad20ec6160a663fc58cff901dc0b48644771d403388790185b81f4596e6ff2da1c49f0a5adcae57c4c38f0e30ed0 SHA512 adcef6699063a0e6735acdb6b7c38973a633b60a8fb15286d3341d78b87819b185598217b9a5a964f4e241163fd0fa89685715f9f99018d976a2116640dabcd8
+EBUILD sdnotify-0.3.2.ebuild 528 BLAKE2B 59a7b3c1468725b902a9146be05598c9da9ed7592115585c67ae0f86fb26af26a89be7e85f7a818e7ac4b7cd2d4e9db7ce46cb8162e71ff8c007b70e64e33b72 SHA512 a5cbff412ca36633ae2c6c92cab4ddb44a6b37ba227600eddf0d969cf21161a968d40c743565b1a9d08a480d0bedd0bf583d3a684e164aa0cb4a8672720ecd7d
+MISC metadata.xml 850 BLAKE2B 0673df4f05a46bc8b09c95d748c8d895635f2787ab7b6158d6ed8aa3abd0aae4d493198f0ba1a89088624bb74b66eb37e4638ca0e1121d4d3fc57ac3257fb466 SHA512 208120e5365d7553aa685ecfc1168fc58b215367c89d9a186b6183091bf736b05cc145cf121257e9c7b9571ab517eaf1a7bf7573bddb7d7a8a5c030f903288a5
diff --git a/dev-python/sdnotify/metadata.xml b/dev-python/sdnotify/metadata.xml
new file mode 100644
index 000000000000..13dc4abe565e
--- /dev/null
+++ b/dev-python/sdnotify/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>bbethke@gmail.com</email>
+ <name>Brett Bethke</name>
+ </maintainer>
+ <remote-id type="pypi">sdnotify</remote-id>
+ <remote-id type="github">bb4242/sdnotify</remote-id>
+ </upstream>
+ <longdescription>
+ This is a pure Python implementation of the systemd sd_notify
+ protocol. This protocol can be used to inform systemd about
+ service start-up completion, watchdog events, and other service
+ status changes. Thus, this package can be used to write system
+ services in Python that play nicely with systemd. sdnotify is
+ compatible with both Python 2 and Python 3.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sdnotify/sdnotify-0.3.1.ebuild b/dev-python/sdnotify/sdnotify-0.3.1.ebuild
new file mode 100644
index 000000000000..79c0597d5972
--- /dev/null
+++ b/dev-python/sdnotify/sdnotify-0.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of systemd's service notification protocol (sd_notify)"
+HOMEPAGE="
+ https://github.com/bb4242/sdnotify
+ https://pypi.org/project/sdnotify/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/sdnotify/sdnotify-0.3.2.ebuild b/dev-python/sdnotify/sdnotify-0.3.2.ebuild
new file mode 100644
index 000000000000..d7fb6dddc070
--- /dev/null
+++ b/dev-python/sdnotify/sdnotify-0.3.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of systemd's service notification protocol (sd_notify)"
+HOMEPAGE="https://github.com/bb4242/sdnotify
+ https://pypi.org/project/sdnotify/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"