summaryrefslogtreecommitdiff
path: root/dev-python/scrypt/scrypt-0.8.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/scrypt/scrypt-0.8.18.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/scrypt/scrypt-0.8.18.ebuild')
-rw-r--r--dev-python/scrypt/scrypt-0.8.18.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/scrypt/scrypt-0.8.18.ebuild b/dev-python/scrypt/scrypt-0.8.18.ebuild
new file mode 100644
index 000000000000..a945c11c5375
--- /dev/null
+++ b/dev-python/scrypt/scrypt-0.8.18.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://github.com/holgern/py-scrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="dev-libs/openssl:0="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest