summaryrefslogtreecommitdiff
path: root/dev-python/scripttest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/scripttest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/scripttest')
-rw-r--r--dev-python/scripttest/Manifest5
-rw-r--r--dev-python/scripttest/metadata.xml11
-rw-r--r--dev-python/scripttest/scripttest-1.2-r1.ebuild25
-rw-r--r--dev-python/scripttest/scripttest-1.3.0.ebuild26
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/scripttest/Manifest b/dev-python/scripttest/Manifest
new file mode 100644
index 000000000000..7b98595a384b
--- /dev/null
+++ b/dev-python/scripttest/Manifest
@@ -0,0 +1,5 @@
+DIST ScriptTest-1.2.tar.gz 7208 BLAKE2B 07e63e636ca88b47c0cb9129cf4fc02838287b4ea1cc6b2ae47eec1320ad200179d4a6b8f59860aaa24aac75edbe1d55e45da2de91ef222e621f74667ea79c49 SHA512 0dc09e6af5554f38aca6ee45b9afad2fa4c1c53a4d3c43edff95bbd6ea8d57e94bf6b7bdcfd26afff6bf2b10690795bd2816013801911f726c67e8171546cad2
+DIST scripttest-1.3.0.tar.gz 14885 BLAKE2B 1984bb175b49248bd369d2d2ed6f70051113285b6870bce67e0c2203d29b4c5b2735fa96dfef7ee11aa38db74e9beb026bbc946c8549b2810f6b90e896bcae0e SHA512 038bfb1726bff85b6e3675be51db829d3519b47665266f6ae1d3c5c6f4f06e7b16742262ca1ba240544e9bd39ae96c1be0bd5e8583736f72bb04241a1bb8acf6
+EBUILD scripttest-1.2-r1.ebuild 543 BLAKE2B f155cc6257076459eeb3ce5b4cffb30dd1035da6f987bfbfe49995d6d6d3b497d9fd603484ab98fb686be5450b1e4e14a6264b1bb581523314a11d088e6582f6 SHA512 33787bcc9603d6e0038912aef34bff3825f4c3e82da172b8cac72cb181c91fe8101c1bd2f7abe499d83292a3bc65631e5758ce4a171202f390ca9666530452bf
+EBUILD scripttest-1.3.0.ebuild 637 BLAKE2B b8c929d20881fe0825342c14a13490c7fc0b9403cc04e2781bd3216bdf7bf8953500294dca3cf7b3097db202cb4d03f41f0ca9c96babe3704c5be2683c7386b9 SHA512 f885787ce63fb26d87c2ec288889b2efe4281491fd4a02c93a017ebdc59a457576b5c28fd8b847e6f905ad841678bcdea638b1c55c189c5563dfef8c2db58109
+MISC metadata.xml 313 BLAKE2B 70bc88a2b745b46e0da17a41ef420dd6b0ae2fcb3f444ed6be3d6bcdea63a4b0019790e0dba51b46c3a5d82c93f667f25b116793623604edad4d01841af723f5 SHA512 ae1c2257d3367ea3bdba8e040c0efd98674fe833f7a025c1b554e8cae6e1a41de6867e63c3d792593fa2f4baab158b046d2efaa08d6c8376f8ec749cdc7d4ff9
diff --git a/dev-python/scripttest/metadata.xml b/dev-python/scripttest/metadata.xml
new file mode 100644
index 000000000000..f8b627581028
--- /dev/null
+++ b/dev-python/scripttest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ScriptTest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/scripttest/scripttest-1.2-r1.ebuild b/dev-python/scripttest/scripttest-1.2-r1.ebuild
new file mode 100644
index 000000000000..6d1cdd5d8eac
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="ScriptTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="https://pypi.org/project/ScriptTest/
+ https://github.com/pypa/scripttest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/scripttest/scripttest-1.3.0.ebuild b/dev-python/scripttest/scripttest-1.3.0.ebuild
new file mode 100644
index 000000000000..293588dbb381
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="https://pypi.org/project/ScriptTest/
+ https://github.com/pypa/scripttest"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pypa/scripttest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}