summaryrefslogtreecommitdiff
path: root/dev-python/scripttest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-10 01:49:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-10 01:49:12 +0000
commit7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (patch)
tree5cd412784dc4fb63a7f56eb252196ed9dd6980c4 /dev-python/scripttest
parent0b832a429ecd6081aa9faa0eb262303b019d87ea (diff)
gentoo auto-resync : 10:03:2025 - 01:49:12
Diffstat (limited to 'dev-python/scripttest')
-rw-r--r--dev-python/scripttest/Manifest2
-rw-r--r--dev-python/scripttest/scripttest-2.0.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/scripttest/Manifest b/dev-python/scripttest/Manifest
index c2b63433312c..9d0a224f7a2a 100644
--- a/dev-python/scripttest/Manifest
+++ b/dev-python/scripttest/Manifest
@@ -1,3 +1,5 @@
DIST scripttest-1.3.0.gh.tar.gz 14885 BLAKE2B 1984bb175b49248bd369d2d2ed6f70051113285b6870bce67e0c2203d29b4c5b2735fa96dfef7ee11aa38db74e9beb026bbc946c8549b2810f6b90e896bcae0e SHA512 038bfb1726bff85b6e3675be51db829d3519b47665266f6ae1d3c5c6f4f06e7b16742262ca1ba240544e9bd39ae96c1be0bd5e8583736f72bb04241a1bb8acf6
+DIST scripttest-2.0.gh.tar.gz 14676 BLAKE2B 12515127e02d2ad8d4a60517571066ed3f381e21d7c64424f436a97d331e1a0d1b7ab7f6898b1a97dc2d379a59184a409b1ad35c472d7bf794953fbd5eeed150 SHA512 c3a2ccb1856c11a377287829683e63f3c8b4653ee778596a606195712bb8c01dcfb6e98408ac1012bfb3d0b45853f3076301f6a42e1f03bebf1df8a06e9d15f9
EBUILD scripttest-1.3.0-r2.ebuild 604 BLAKE2B caf08add86c97f8c5c99c2864755c7f2c811808304769d31e4ca791b85a7e81c61eff2645bc48482f4d6011b4ea04f268f36517c5bd2c15507e81a1e71f8135f SHA512 3cee6d3ad80afa50145e88dcaad5180c30f71b0b5c7f3784648cb156a6b5800b50c59786844a2b6d0d6cd6d9715553c247518e42644ddc7bc1df063580791843
+EBUILD scripttest-2.0.ebuild 612 BLAKE2B 9dd46859706306e4a293df1bdd8df7a73b8b4ad4848191b5489d4244375dbd01e93b38a4227050f731fbd4b5883de7228e1552b636cfc5be379738105e5c08ec SHA512 b09e376c7c6a4f44eecb4f52dd49b6c0bef25c8b0c12f9dfdc0ae8a36dc2b9a7451e9be23a6c301f49432033a7d3b23a5abbce2c92115c37e63fa01130a48456
MISC metadata.xml 393 BLAKE2B 749fa982e12a5c1864a6268a9d589fdf30888662f66a9f8391207282f15eb13f006a4996db23811d5641601bb8c92e554c1e2247e939e72dab21a18eb54a70d5 SHA512 edb02776963e15f752a7b8a4a758e07c8d649a18815fb7e61fa567df34d6e82c18f8889fba74334b8c3657cf8327b215647a1d99acd2b16b01c712b1d3f4f2d1
diff --git a/dev-python/scripttest/scripttest-2.0.ebuild b/dev-python/scripttest/scripttest-2.0.ebuild
new file mode 100644
index 000000000000..ff3cb4142ed0
--- /dev/null
+++ b/dev-python/scripttest/scripttest-2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="
+ https://pypi.org/project/scripttest/
+ https://github.com/pypa/scripttest/
+"
+SRC_URI="
+ https://github.com/pypa/scripttest/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest