summaryrefslogtreecommitdiff
path: root/dev-python/scripttest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/scripttest
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/scripttest')
-rw-r--r--dev-python/scripttest/Manifest3
-rw-r--r--dev-python/scripttest/scripttest-1.3.0-r1.ebuild4
-rw-r--r--dev-python/scripttest/scripttest-1.3.0-r2.ebuild25
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/scripttest/Manifest b/dev-python/scripttest/Manifest
index e24937e7c665..84634235af08 100644
--- a/dev-python/scripttest/Manifest
+++ b/dev-python/scripttest/Manifest
@@ -1,3 +1,4 @@
DIST scripttest-1.3.0.tar.gz 14885 BLAKE2B 1984bb175b49248bd369d2d2ed6f70051113285b6870bce67e0c2203d29b4c5b2735fa96dfef7ee11aa38db74e9beb026bbc946c8549b2810f6b90e896bcae0e SHA512 038bfb1726bff85b6e3675be51db829d3519b47665266f6ae1d3c5c6f4f06e7b16742262ca1ba240544e9bd39ae96c1be0bd5e8583736f72bb04241a1bb8acf6
-EBUILD scripttest-1.3.0-r1.ebuild 569 BLAKE2B ab58b15a4eb75ded0f7d451b3acf1b9c9696b4b7d9c03e821c53478a65079ef8ae7d68f9a0dbe560fe5364aa173dbe832ae89013494cd402181c1972f3d9ab1a SHA512 8aae651c7de79fd96b3a8f2ec6606880bf204c2f769acae553bfd95ac2eb1cd37081bfab1cd994cd102b53c83dea609809df163c8e666cc292a6e53eb581103e
+EBUILD scripttest-1.3.0-r1.ebuild 582 BLAKE2B c54cf0618534b3578ce1a924e7135b3d929a074113a61ad5994b2bcb32a55c1ce2c8e9c6de0b73ad804ff8bbe80e3e1e775fcd969c2fe43859461af6a2ecbb92 SHA512 4def7da6dfdc84a07d5ca363488be043e994e81b4636b2a007474481dedb869e4e57bb66744e3a1a07db8ea48b04cfbb45a84e4d399ff1e0dc529c849f13c71d
+EBUILD scripttest-1.3.0-r2.ebuild 605 BLAKE2B 5c0bbaefe589ffce8edcab5c558b53981448fec428ec0a4c1122e2d97ab4c810884ec934696ca679ae824237505ab4fd2d728ce864824339b878f6a2d8a58d37 SHA512 8942160c6847688e32afe5793cde1e33bfb10893a3cb82dbf4ea77c9b97cb600dc328240d6a7e524434b4194db25d9119985516f70bb8373dab27a18876e83e6
MISC metadata.xml 369 BLAKE2B a74d3242d3ead45eb3efc8ab6d63e782e8683ef0cae61172141720c0f51c1a98a9709be54c46d9328ad113f590dd82016ccf269f5954401b48394417da340d2f SHA512 2af70b358850dcf9cbd2b2fe427489c2d33ffeaf6b331b6e5fbdeb0a097f857c5a981f1170ceb68428c319e0225d6c7fdd9ff7bda75bf0204863e0acd67ef33d
diff --git a/dev-python/scripttest/scripttest-1.3.0-r1.ebuild b/dev-python/scripttest/scripttest-1.3.0-r1.ebuild
index 6a6be6c5075a..c89bf6e45053 100644
--- a/dev-python/scripttest/scripttest-1.3.0-r1.ebuild
+++ b/dev-python/scripttest/scripttest-1.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,6 +14,6 @@ SRC_URI="https://github.com/pypa/scripttest/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
distutils_enable_tests pytest
diff --git a/dev-python/scripttest/scripttest-1.3.0-r2.ebuild b/dev-python/scripttest/scripttest-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..2735795f8652
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.3.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="
+ https://pypi.org/project/scripttest/
+ https://github.com/pypa/scripttest/
+"
+SRC_URI="
+ https://github.com/pypa/scripttest/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest