summaryrefslogtreecommitdiff
path: root/dev-python/sclapp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sclapp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sclapp')
-rw-r--r--dev-python/sclapp/Manifest4
-rw-r--r--dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch40
-rw-r--r--dev-python/sclapp/metadata.xml8
-rw-r--r--dev-python/sclapp/sclapp-0.5.3-r1.ebuild28
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/sclapp/Manifest b/dev-python/sclapp/Manifest
new file mode 100644
index 000000000000..93db3a762fef
--- /dev/null
+++ b/dev-python/sclapp/Manifest
@@ -0,0 +1,4 @@
+AUX sclapp-0.5.3-testsuite-fix-from-r235.patch 1276 BLAKE2B be9b737675d5aaf9f7f190b27d7685c7fe4cb895eecf1de37e75cf568f563a20dba274417bf5878942ce2fa1ae6b4f5b1d40fa27000998fe859710c112d4e28c SHA512 2bf15b6423db0ff7fd113eab3014dbf0f8327a683d7c9570ae086164b5a364413d5bc1f5637deebef52b4f04f089cb99ca2a86c00445b372a57358d711618f8f
+DIST sclapp-0.5.3.tar.gz 47646 BLAKE2B 7c36d675c38d9ff79cc7a84d88da0ceb1872d882e997a366c11dd4098172420d691ea2e953197f9a664ceeed337b21a247cb680a40c272e400fea7f5eb58719b SHA512 e615310b2ede517717cf8ef70aca02c070676d71fb8880e381e3cc66d5c6006e47b4dd7c4355dbcb34e76898ce7a7a2e4522454490353970ac185c5d1963e49f
+EBUILD sclapp-0.5.3-r1.ebuild 577 BLAKE2B fe2a187d3c1b797dcbc5d494ed41d1f95bb39495bff6cbef5d13abb246f37a3f0fa5c1d7cd37c6d4b0d40216a5a6c2a2940c8756e5a275cf5554722f0be19011 SHA512 757a544d7b349101ff75ea2146eb7682cf933fa1be09d6f81a4a2c4b4f91a1d6f389b447160648a44490d828fdffe7efb553a42d9c61eba7f3bba87f274d8920
+MISC metadata.xml 249 BLAKE2B 3647e2ef94ad009c86dc9d42c1396ad9420ade97042882b8d8f60f676c465cfd6ea3cea4b77caccadd99eb0cbe1ef83b18b799ec676da4ecfbff528d21bb5ffb SHA512 334ac61f9acc5c4917fd29afb3b420b1689b39be80cada419bed1db033e64130866d0995abe5f1c75eb1290f51734e9ad4c8d06fd8b49c288ecf617a0693d273
diff --git a/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch b/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch
new file mode 100644
index 000000000000..45965f01b1de
--- /dev/null
+++ b/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch
@@ -0,0 +1,40 @@
+=== modified file 'NEWS'
+--- NEWS 2009-01-14 11:11:28 +0000
++++ NEWS 2009-12-21 14:12:02 +0000
+@@ -25,6 +25,9 @@
+
+ (Forest Bond)
+
++ * Fixed output protection test that was failing on some systems.
++ (Forest Bond)
++
+
+ sclapp 0.5.3 2008-07-21
+ =======================
+
+=== modified file 'tests/output_protection.py'
+--- tests/output_protection.py 2008-05-18 21:46:03 +0000
++++ tests/output_protection.py 2009-12-21 14:12:02 +0000
+@@ -109,8 +109,10 @@
+ exceptions = ()):
+ def test_fn():
+ pid = failure_fn(main_fn)
+- assertLogFileContainsExactly('foo', foos)
+- assertLogFileContainsExactly('bar', bars)
++ if foos is not None:
++ assertLogFileContainsExactly('foo', foos)
++ if bars is not None:
++ assertLogFileContainsExactly('bar', bars)
+ for signal in signals:
+ assertSignalCaught(signal, pid)
+ for exception in exceptions:
+@@ -171,7 +173,7 @@
+ 'test_stdout_fails_without_signal_handling_without_output_protection',
+ _stdout_fails,
+ main_without_signal_handling_without_output_protection,
+- 2, 2, ()
++ 2, None, ()
+ )))
+ test_stdout_stderr_fail_without_signal_handling_without_output_protection = (
+ staticmethod(_make_test_fn(
+
diff --git a/dev-python/sclapp/metadata.xml b/dev-python/sclapp/metadata.xml
new file mode 100644
index 000000000000..6d2298876faa
--- /dev/null
+++ b/dev-python/sclapp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sclapp/sclapp-0.5.3-r1.ebuild b/dev-python/sclapp/sclapp-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..9e2c41922be7
--- /dev/null
+++ b/dev-python/sclapp/sclapp-0.5.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for writing simple command-line applications"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://www.alittletooquiet.net/media/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pexpect[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-testsuite-fix-from-r235.patch"
+)
+
+python_test() {
+ esetup.py test
+}