summaryrefslogtreecommitdiff
path: root/dev-python/scipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-12 11:25:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-12 11:25:13 +0000
commitc9818073ff1b4fa99a5b484aa5f5e02d4aa487b9 (patch)
treed3a9f25e0d8635674d2b985d0ec81b36791f4d10 /dev-python/scipy
parent343576b60d95d89e6165d24813c57e3bd92d3911 (diff)
gentoo auto-resync : 12:12:2023 - 11:25:13
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest2
-rw-r--r--dev-python/scipy/files/scipy-1.11.0-determinant-1x1-matrix.patch69
-rw-r--r--dev-python/scipy/files/scipy-1.11.1-cython-3.patch45
3 files changed, 0 insertions, 116 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index 2b5fa847c1e5..94ab354057c2 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -1,5 +1,3 @@
-AUX scipy-1.11.0-determinant-1x1-matrix.patch 2757 BLAKE2B a91cf26f38f7b783a98b0664f959ca2da9a0c7eb746c4e5d325562d6395eb239761049686671e5dd1e785652b582b59091026cc6c5cbae7070f18731f50d9f84 SHA512 35e2e7f650bc97a84d9a69e2985e71b43bdb984ceed098fefd16e3faef65cc8e5d31761fcbe5c826072e76956f619e87d1a154e159c283e0c9f6679402d5e1d5
-AUX scipy-1.11.1-cython-3.patch 1541 BLAKE2B a0202aa0a96733886c4947c5442af3e2e6cbec28d752a25a983942a011ab50ac69ed8ca6b01d58ece7f1e4593f4a0b4ab47a866ce84c917da6353e92cdf98a37 SHA512 7d6814dd4f3d0fc458c3da744fb7116b684fe1264fbe172955529029ea4fb3d78f8a8cf0e79996791a935f50bfea802f594d92b3a8837c15de5fa81ce0635501
DIST scipy-1.11.3.tar.gz 56335652 BLAKE2B 2b35c24522b2bd498b4ebe84a854c8ec1e62917e7b899b3e3526abb9780c1e56f8e776a3bb1eab1bedb17a273fac881e5ffdaac808084a4f5a5f97428bff1029 SHA512 6491c4e479d9f4f02e677396a25ddca947a0dc6c009fc2ec34c658012a6224c0b535f14045bb011fbde9973ea987d184574ed64e6760c31798ec860eb0896fcf
DIST scipy-1.11.4.tar.gz 56336202 BLAKE2B a2091a1edb54eb73c2de6ed8c62a7e571f37b247c9af50947aa97b739342c96b87b20a82b1a238c859fa532c84249cbadde228366dcea3555e9a506c1ae55031 SHA512 2eb403f6de9723b411d948b8e1b5457078704c605b8e760d42362c82d802e167eaaf701ddb8b480af2bdf2efe4dbf66fcc4e97321519bb8dab19b0e2a8976beb
DIST scipy-html-1.11.0.zip 50421508 BLAKE2B cb5e4a4f8817a80f54ae73b4a47ba22d2438df46ebfe27ef5fdc2695fdd983226f4ccae925bf82b15d01ced4f4b6807384ecadac5e1aa7700aa887ad06b7d065 SHA512 33718bbd5e828687d93fccc441a53b6a2e8f54ac4952d3b69d4c4668f55cb6ef5aba33df9acda20b2400effa5ae71767b2a5602a365ad2045a6edd24ff89c253
diff --git a/dev-python/scipy/files/scipy-1.11.0-determinant-1x1-matrix.patch b/dev-python/scipy/files/scipy-1.11.0-determinant-1x1-matrix.patch
deleted file mode 100644
index 248ee5299f2c..000000000000
--- a/dev-python/scipy/files/scipy-1.11.0-determinant-1x1-matrix.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-https://github.com/scipy/scipy/issues/18759
-https://github.com/scipy/scipy/pull/18763
-https://github.com/scipy/scipy/commit/61d892c9faa543ad80bd5e2d0bf69821188487e0
-
-From 61d892c9faa543ad80bd5e2d0bf69821188487e0 Mon Sep 17 00:00:00 2001
-From: Ilhan Polat <ilhanpolat@gmail.com>
-Date: Tue, 27 Jun 2023 12:00:38 +0200
-Subject: [PATCH] MAINT:linalg.det:Return scalars for singleton inputs (#18763)
-
---- a/scipy/linalg/_basic.py
-+++ b/scipy/linalg/_basic.py
-@@ -1001,7 +1001,8 @@ def det(a, overwrite_a=False, check_finite=True):
- det : (...) float or complex
- Determinant of `a`. For stacked arrays, a scalar is returned for each
- (m, m) slice in the last two dimensions of the input. For example, an
-- input of shape (p, q, m, m) will produce a result of shape (p, q).
-+ input of shape (p, q, m, m) will produce a result of shape (p, q). If
-+ all dimensions are 1 a scalar is returned regardless of ndim.
-
- Notes
- -----
-@@ -1066,11 +1067,17 @@ def det(a, overwrite_a=False, check_finite=True):
-
- # Scalar case
- if a1.shape[-2:] == (1, 1):
-- if a1.dtype.char in 'dD':
-- return np.squeeze(a1)
-+ # Either ndarray with spurious singletons or a single element
-+ if max(*a1.shape) > 1:
-+ temp = np.squeeze(a1)
-+ if a1.dtype.char in 'dD':
-+ return temp
-+ else:
-+ return (temp.astype('d') if a1.dtype.char == 'f' else
-+ temp.astype('D'))
- else:
-- return (np.squeeze(a1).astype('d') if a1.dtype.char == 'f' else
-- np.squeeze(a1).astype('D'))
-+ return (np.float64(a1.item()) if a1.dtype.char in 'fd' else
-+ np.complex128(a1.item()))
-
- # Then check overwrite permission
- if not _datacopied(a1, a): # "a" still alive through "a1"
---- a/scipy/linalg/tests/test_basic.py
-+++ b/scipy/linalg/tests/test_basic.py
-@@ -930,6 +930,23 @@ class TestDet:
- def setup_method(self):
- self.rng = np.random.default_rng(1680305949878959)
-
-+ def test_1x1_all_singleton_dims(self):
-+ a = np.array([[1]])
-+ deta = det(a)
-+ assert deta.dtype.char == 'd'
-+ assert np.isscalar(deta)
-+ assert deta == 1.
-+ a = np.array([[[[1]]]], dtype='f')
-+ deta = det(a)
-+ assert deta.dtype.char == 'd'
-+ assert np.isscalar(deta)
-+ assert deta == 1.
-+ a = np.array([[[1 + 3.j]]], dtype=np.complex64)
-+ deta = det(a)
-+ assert deta.dtype.char == 'D'
-+ assert np.isscalar(deta)
-+ assert deta == 1.+3.j
-+
- def test_1by1_stacked_input_output(self):
- a = self.rng.random([4, 5, 1, 1], dtype=np.float32)
- deta = det(a)
diff --git a/dev-python/scipy/files/scipy-1.11.1-cython-3.patch b/dev-python/scipy/files/scipy-1.11.1-cython-3.patch
deleted file mode 100644
index 4b402b5c469d..000000000000
--- a/dev-python/scipy/files/scipy-1.11.1-cython-3.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From d0dd5c957876300c33db303042dfa4888b1696f4 Mon Sep 17 00:00:00 2001
-From: Matus Valo <matusvalo@gmail.com>
-Date: Sun, 2 Jul 2023 23:12:51 +0200
-Subject: [PATCH 1/2] Add cython_optimize.pxd to _cython_tree
-
----
- scipy/optimize/meson.build | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/scipy/optimize/meson.build b/scipy/optimize/meson.build
-index 26458b05cd7..7c6097acf55 100644
---- a/scipy/optimize/meson.build
-+++ b/scipy/optimize/meson.build
-@@ -206,6 +206,10 @@ endif
-
- _dummy_init_optimize = fs.copyfile('__init__.py')
-
-+_cython_tree = [
-+ fs.copyfile('cython_optimize.pxd'),
-+]
-+
- opt_gen = generator(cython,
- arguments : cython_args,
- output : '@BASENAME@.c',
-
-From b8621185fa61d6b3610e2cb62eae3b81434952c9 Mon Sep 17 00:00:00 2001
-From: Matus Valo <matusvalo@gmail.com>
-Date: Sun, 2 Jul 2023 23:28:41 +0200
-Subject: [PATCH 2/2] Use absolute import in cython_optimize.pxd
-
----
- scipy/optimize/cython_optimize.pxd | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/scipy/optimize/cython_optimize.pxd b/scipy/optimize/cython_optimize.pxd
-index d5a0bdd758e..d35f8da68b3 100644
---- a/scipy/optimize/cython_optimize.pxd
-+++ b/scipy/optimize/cython_optimize.pxd
-@@ -7,5 +7,5 @@
- # support. Changing it causes an ABI forward-compatibility break
- # (gh-11793), so we currently leave it as is (no further cimport
- # statements should be used in this file).
--from .cython_optimize._zeros cimport (
-+from scipy.optimize.cython_optimize._zeros cimport (
- brentq, brenth, ridder, bisect, zeros_full_output)