summaryrefslogtreecommitdiff
path: root/dev-python/scikit-image
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 20:14:38 +0100
commit34f71cb8541190212fa250ceb3dafb53f383beea (patch)
tree75894a0bd212c9a6464b37d48f418fcb5cc3ff82 /dev-python/scikit-image
parent18bf6672cbde96e8498ce4bfc974af9bb4f95613 (diff)
gentoo auto-resync : 04:04:2024 - 20:14:38
Diffstat (limited to 'dev-python/scikit-image')
-rw-r--r--dev-python/scikit-image/Manifest3
-rw-r--r--dev-python/scikit-image/scikit-image-0.23.0_rc2.ebuild97
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/scikit-image/Manifest b/dev-python/scikit-image/Manifest
index 9642e68c2b5a..c748e97b3363 100644
--- a/dev-python/scikit-image/Manifest
+++ b/dev-python/scikit-image/Manifest
@@ -1,4 +1,7 @@
AUX scikit-image-0.22.0-no-numpydoc.patch 1664 BLAKE2B 65a4b565069bf21a44deae1de9cd4e66a9788e7cf3928bdf52b65325be89952a287ae713f019530f97effd92e462ea2aa94b4ad334c41d0f03d8c8d66b759f92 SHA512 38c38f4755dcb106b0683ea091b75d0923aa63e123c0e8c09eead13beec573dc65a696df955e6d58e873fadc9ec2bc95f3823ba2cb875477b627c09caa32c029
+DIST scikit-image-data-15735b54e85c02427f07c71e6456723495034805.tar.bz2 143900901 BLAKE2B c1352e76337250fe1a9d6e07f08b6c9b1e0aed922ab8e0a3a4a1ea175f593b3375522e59550d30a22d392c34fef26d638c007c2af3d991887e02e7c68e56ebbb SHA512 d113dd258b35be710d841f9900cfbfe7103d1190b042489de88dd504b56277edac9a98fed5517e57725c5292fe26528267a06ff313bf6500b669d872c4481146
DIST scikit_image-0.22.0.tar.gz 22685018 BLAKE2B 7d0a65f75f5a58211e21501d6cc6a638f1d36e9a2198a3ad9ff2f230890496c41d5e6cdaed02bbaa62f26aa57fd24fc993656cbdfc2c9c9750147d0f325e56f1 SHA512 4b8c097cd5465f57b1c0879363fe3bdc0941decf2d1f8a881f13f2b7f3207c425f3a0cdcb4be0eed7b33d3ac2f3f8b1835d1cfa69cd3fa2ff5e0be11385fef48
+DIST scikit_image-0.23.0rc2.tar.gz 22677632 BLAKE2B b663065650e25a33ffec80ddd05df622bc62b1c1d3d0a831488d4dd23291b4f125458ae335782762b1d4dc1efa8cbedd5fcd7e6bbe62003967209e4ca4179bca SHA512 aa5f27d571ea49276aba8443a691b30a576d52145a17f13b8ea080a2abf0ed01c57fe50324c05e72bb4662a9ddbb480be94be6784ac3220ed6853b12d94ae06b
EBUILD scikit-image-0.22.0.ebuild 1822 BLAKE2B 4e59a3b890c0fcaa173f05cf6b10db34a2e915fd97466b6b2dec59fbbc8caefce18171b4df97b0b8b585079e9bd3d803ba83a12c33aff620494dfb971cdaa349 SHA512 ff87e164b115cce39c730fb28f15d4d9091f831886a2b38611cde1c79827205fc40eab36ab60b2487bdf947333170d1452fcb1aee3a8922ef5b899a9792a1933
+EBUILD scikit-image-0.23.0_rc2.ebuild 3266 BLAKE2B aacd618a08f715570ff2a40d7a62ee8573e553bf6b278fa611c42b6f80a40bf5ad654ea801fe5703331aef88c7e1e12bda78984ad003940bfc99b237f5bcfe86 SHA512 42bdc3e4b5fdfb91fb1daaa6c36d33a96fb4b4d68c7eefcc15e7728e2aa7e9a296c02f53d4ea6c4570ab363431a4d854982924b422d45f3eafccc999d99e5011
MISC metadata.xml 695 BLAKE2B 11487b964bde2ce1a39a8680bc3cc62045c4a7e2e17844de830d5f0e043660c431cd002a2a0fc19acb4c0262289ee280195475dd1f8b35f6a51ce0df369871f8 SHA512 fca83587d443373fc7219911900105676bdba5a7ced07ac00a9ab5cbe361d8ca1175b02b04fa53cdbde6f198a986b21f989baf32139cd76b7d1b2b78034d3142
diff --git a/dev-python/scikit-image/scikit-image-0.23.0_rc2.ebuild b/dev-python/scikit-image/scikit-image-0.23.0_rc2.ebuild
new file mode 100644
index 000000000000..c5a106b9ecb8
--- /dev/null
+++ b/dev-python/scikit-image/scikit-image-0.23.0_rc2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=meson-python
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+TEST_DATA_COMMIT=15735b54e85c02427f07c71e6456723495034805
+DESCRIPTION="Image processing routines for SciPy"
+HOMEPAGE="
+ https://scikit-image.org/
+ https://github.com/scikit-image/scikit-image/
+ https://pypi.org/project/scikit-image/
+"
+SRC_URI+="
+ test? (
+ https://gitlab.com/scikit-image/data/-/archive/${TEST_DATA_COMMIT}/scikit-image-data-${TEST_DATA_COMMIT}.tar.bz2
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/imageio-2.33[${PYTHON_USEDEP}]
+ >=dev-python/lazy_loader-0.3[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.8[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.23[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.9[sparse(+),${PYTHON_USEDEP}]
+ >=dev-python/tifffile-2022.8.12[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-python/cython-3.0.4[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CONTRIBUTORS.txt RELEASE.txt )
+
+# xdist does not work with this test suite
+distutils_enable_tests pytest
+# There is a programmable error in your configuration file:
+#distutils_enable_sphinx doc/source dev-python/numpydoc dev-python/myst-parser
+
+src_test() {
+ # for some reason, upstream refetches data that's already in the tarball
+ # sigh
+ mkdir -p "${HOME}/.cache/scikit-image" || die
+ mv skimage "${HOME}/.cache/scikit-image/${PV/_/}" || die
+
+ # This is a true horror, sigh
+ local cache_dir=${HOME}/.cache/scikit-image/${PV/_/}/data
+ pushd "${WORKDIR}/data-${TEST_DATA_COMMIT}" >/dev/null || die
+ cp Tests_besides_Equalize_Otsu/add18_entropy/rank_filters_tests_3d.npz \
+ Tests_besides_Equalize_Otsu/gray_morph_output.npz \
+ brain.tiff cells3d.tif eagle.png \
+ "${cache_dir}/" || die
+ cp Normal_Epidermis_and_Dermis_with_Intradermal_Nevus_10x.JPG "${cache_dir}"/skin.jpg || die
+ cp pivchallenge/B/B001_1.tif "${cache_dir}"/pivchallenge-B-B001_1.tif || die
+ cp pivchallenge/B/B001_2.tif "${cache_dir}"/pivchallenge-B-B001_2.tif || die
+ cp kidney-tissue-fluorescence.tif "${cache_dir}"/kidney.tif || die
+ cp lily-of-the-valley-fluorescence.tif "${cache_dir}"/lily.tif || die
+ cp astronaut_rl.npy "${cache_dir}/../restoration/tests/" || die
+ popd > /dev/null || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # tests for downloading all data files, including these not needed
+ # by any actual tests
+ data/tests/test_data.py::test_download_all_with_pooch
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs skimage -p localserver -o xfail_strict=False
+}
+
+pkg_postinst() {
+ optfeature "FITS io capability" dev-python/astropy
+ optfeature "GTK" dev-python/pygtk
+ optfeature "Parallel computation" dev-python/dask
+ optfeature "io plugin providing most standard formats" dev-python/imread
+ optfeature "plotting" dev-python/matplotlib
+ optfeature "wavelet transformations" dev-python/pywavelets
+ optfeature "io plugin providing a wide variety of formats, including specialized formats using in medical imaging." dev-python/simpleitk
+}