summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-17 15:39:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-17 15:39:26 +0000
commitf1317d9384e4b8cbbd93ff4ceb8bd87fa9d3a4f1 (patch)
treedd8d85d0456d78dcba0d13e7b713ae23c4f073dc /dev-python/scikit-build
parentbcea7077fd4cd5045b1a07fac9619e1d2fb4e897 (diff)
gentoo auto-resync : 17:12:2022 - 15:39:26
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest2
-rw-r--r--dev-python/scikit-build/scikit-build-0.16.4.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index b6700dc96d8e..acee2ee966a9 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,5 +1,7 @@
DIST scikit-build-0.16.2.tar.gz 269822 BLAKE2B 4fe7d8f3c3a993f1832d94896068b6bede1eededb4d85e3332137f516819d167102a1eb2fde6dfe4ad187d0483a4e962311a4ca56f3aa5a4eff0c96a187ca052 SHA512 ae8dfd74c638e5cda127b24070c4e491ec51a69b35eae476f5f74a54ba97419d69e984ae7dc132782c77472852358d9d984650db4e6984decad74aadceecfa05
DIST scikit-build-0.16.3.tar.gz 270429 BLAKE2B 32930041e64750dc4ee7d496bf6541bcc3f75c5fbddadb95d3424eec2309381ac6cb67252936fa753b0996db44749d19662575f4f20f174f85c44256d91ec7b7 SHA512 8cec7b01b7a2b892c05a910806b0a3664f5a966165f1a87e9943067afc9b2a2e93657a7a68e47df6578d5d03f1ff0a0bd987e97cf4b0f442d79949f52247968c
+DIST scikit-build-0.16.4.tar.gz 271037 BLAKE2B 6cca8a3c4f4b37228b77ac098650a5eca4ad0f525ca7dcba178f4cffabb7e60e9a7bbba244e64c1a598ab5916f2f47788198eb2a19803d8d0cf7b9792f4e06e2 SHA512 90315ceac4c372e4d7248b4b56b6092362c2c43fbdc180d1a234e057209c508a05d2c6e0a3d0c2587c3adb8957e4c66d5c171a2a2bc3dbf9874a0de58d97d976
EBUILD scikit-build-0.16.2.ebuild 2116 BLAKE2B 14e8f3b0932b47124c9a5c75ebb8d443ca3781eefa22fa7f40c99d39e2ef59ab1c4946bc258423052ba604f07b62e4577832f722a5cac684b8f09c2303402525 SHA512 52afdde7f1db21b82723602b761796392443be15594b92d5b2331a8d0b459966e00d3e465fe22655b918b004bc9e3f4cb58b30dc989bc75e43a2d218a542b78f
EBUILD scikit-build-0.16.3.ebuild 2086 BLAKE2B 8234c15bd6dc53874e5a047385c8d6855bf0b8d2d26de4daf64e7dd34b855e3a125dd10e186aaef40053ab6fb8dca8159a71bf40c4f581997eb95d4ba12a5d73 SHA512 782f5b2476ce979b4936e1ec6a820d292f874c84a6a8c1f4870a0805cc49604a3fd65a8efa74b41db590ee915295e63bc3f264ed8ad80edb866a6aa2cd41aff4
+EBUILD scikit-build-0.16.4.ebuild 2026 BLAKE2B 8a3490ba7be7b821c31ea2c506cb368ce342ce93d623216e172a90ff66e30183661b68ec79423d31d820bf7b69d9a06a5b6ee9b72af781348937190e585a1f78 SHA512 70030e48019bb553dc25af2ef16ae0dc5338b65d4786a9feeb4ab80995fd4868464fde09d4e02a43ec69697a83df0b51cc9032e1a605d5392150406d457f4c3e
MISC metadata.xml 473 BLAKE2B 9d02a79439618fa413f74e4a617b8af042879be7a44c8f1c33e254e985d4f24057321fb2ec0b73074be1f6b67af3984190e48669e19985d6297411c0c5b61a79 SHA512 afc398c6287ce67eb85402832684fd006385e70d28a738ca8c5f1e2d008526621121cd9107a7fbc217a1a5857b54fa1dce3de69c47db58fc76990764b814a36d
diff --git a/dev-python/scikit-build/scikit-build-0.16.4.ebuild b/dev-python/scikit-build/scikit-build-0.16.4.ebuild
new file mode 100644
index 000000000000..385d50bf5126
--- /dev/null
+++ b/dev-python/scikit-build/scikit-build-0.16.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build/
+ https://pypi.org/project/scikit-build/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+src_prepare() {
+ # not packaged
+ sed -i -e '/cmakedomain/d' docs/conf.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # sandbox violations
+ tests/test_hello_cpp.py::test_hello_develop
+ tests/test_issue274_support_default_package_dir.py
+ tests/test_issue274_support_one_package_without_package_dir.py
+ tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
+ tests/test_pep518.py
+ # This fails because of additional item setup.py in sources
+ tests/test_include_exclude_data.py::test_hello_sdist
+ tests/test_include_exclude_data.py::test_hello_sdist_with_base
+ tests/test_issue401_sdist_with_symlinks.py::test_sdist_with_symlinks
+ tests/test_manifest_in.py::test_manifest_in_sdist
+ # Wants internet to install things with pip
+ tests/test_numpy.py::test_pep518_findpython
+ # TODO
+ "tests/test_command_line.py::test_hide_listing[True-bdist_wheel]"
+ )
+ epytest
+}