summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 15:18:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 15:18:09 +0000
commitc66fa6cf106b825bcc6f1beeff9486ff08232cbe (patch)
treed5147c1533df62427a098f373049d1ec15a7fbc3 /dev-python/scikit-build
parent54c42eb42df420f52e032fcba7727c326ef01094 (diff)
gentoo auto-resync : 05:11:2022 - 15:18:09
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest2
-rw-r--r--dev-python/scikit-build/scikit-build-0.16.2.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index f4cbfacd4ce1..af0c5823db10 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,5 +1,7 @@
DIST scikit-build-0.15.0.tar.gz 268691 BLAKE2B f4cb51ee2367bd4ba6f6c1cada15e1e6be731998a914b28edcf703c5a92c409b78b17dddf04a29b24d40f249ffa06eb9d05d36dc30c0e62ee001519c3ca03f58 SHA512 4d9b1d06d48708ff4f2f5fa8c8f264c7ca85946d5842a1254930d9449d6b6386c17392473c3c85147f6573f7256c94c927962cb56fa23a90a5b442de8de8d727
DIST scikit-build-0.16.1.tar.gz 269763 BLAKE2B b5c70c16a68dc8bae67f273c8ecb423d36fb5379e0dbbc55efffe33ab216162db687fc48004aed84b636ad6b99a79be4cef4838509a18b3a6a81375e1cfd544d SHA512 13b23014939b34096849ecdcd7ffcba0638efa19fbcc3c7348fbcf77a4943236b1009ed1ec07e68acd00b10fdd3d3e809e8a131efe0de17f43bcf794b35755e1
+DIST scikit-build-0.16.2.tar.gz 269822 BLAKE2B 4fe7d8f3c3a993f1832d94896068b6bede1eededb4d85e3332137f516819d167102a1eb2fde6dfe4ad187d0483a4e962311a4ca56f3aa5a4eff0c96a187ca052 SHA512 ae8dfd74c638e5cda127b24070c4e491ec51a69b35eae476f5f74a54ba97419d69e984ae7dc132782c77472852358d9d984650db4e6984decad74aadceecfa05
EBUILD scikit-build-0.15.0.ebuild 2060 BLAKE2B a6c8c15666cca1158ccbeb6642a3a1f7714d74aa50765bad8f549ebb397c0ffb7347560b1930834a474f92be12b02197dc507acab0b034990162414574884a65 SHA512 9dce9170ceef5b29130fe7cf5ef3244d96a94fbbe0b11bec9023837e50f4c0a76c01e04934e7cb829f79de04a38ecbc1061ec1a82bc0cbbce1f043567d2638e4
EBUILD scikit-build-0.16.1.ebuild 2122 BLAKE2B 61557bdaf82f4cc09ced5197f5e36f9754c5b96918448a962ca299b53d050d5fedd7286b7182c0de60ade4628e336ee3e7b562804397ab515a204e31c2b1242e SHA512 e02be683f2f425b533394d31ab41997cef3db0df46529546e370bd6898ef108204cedd66fd09afcb376c4fdd6c59d4f825cefa6a9b8b55dac3842bc9aebaac18
+EBUILD scikit-build-0.16.2.ebuild 2122 BLAKE2B 61557bdaf82f4cc09ced5197f5e36f9754c5b96918448a962ca299b53d050d5fedd7286b7182c0de60ade4628e336ee3e7b562804397ab515a204e31c2b1242e SHA512 e02be683f2f425b533394d31ab41997cef3db0df46529546e370bd6898ef108204cedd66fd09afcb376c4fdd6c59d4f825cefa6a9b8b55dac3842bc9aebaac18
MISC metadata.xml 408 BLAKE2B 4cdf98a2ac7e4bd6e1276e0ceadb3ac7849a81c5a9931b1ea5b3087cd7ced5072c390f1b77791732a3470f2cfba6a0537732f3632a156887d7c4046235062d3a SHA512 deb17b2d33bab0a1f713edd2e10b643b8801b3c04b142dd37530d5335bfde5be6e8ffb99177170a8c24380c2958164bec95db50538993fdb681aa1d0408ebf3e
diff --git a/dev-python/scikit-build/scikit-build-0.16.2.ebuild b/dev-python/scikit-build/scikit-build-0.16.2.ebuild
new file mode 100644
index 000000000000..38933b364960
--- /dev/null
+++ b/dev-python/scikit-build/scikit-build-0.16.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build/
+ https://pypi.org/project/scikit-build/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+src_prepare() {
+ # not packaged
+ sed -i -e '/cmakedomain/d' docs/conf.py || die
+ # no pytest-cov
+ sed -i -e '/addopts =/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # sandbox violations
+ tests/test_hello_cpp.py::test_hello_develop
+ tests/test_issue274_support_default_package_dir.py
+ tests/test_issue274_support_one_package_without_package_dir.py
+ tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
+ tests/test_pep518.py
+ # This fails because of additional item setup.py in sources
+ tests/test_include_exclude_data.py::test_hello_sdist
+ tests/test_include_exclude_data.py::test_hello_sdist_with_base
+ tests/test_issue401_sdist_with_symlinks.py::test_sdist_with_symlinks
+ tests/test_manifest_in.py::test_manifest_in_sdist
+ # Wants internet to install things with pip
+ tests/test_numpy.py::test_pep518_findpython
+ # TODO
+ "tests/test_command_line.py::test_hide_listing[True-bdist_wheel]"
+ )
+ epytest
+}