summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
commitbd8ca999980e9c0c9ae40a11789c858bb58769e3 (patch)
tree355d68a84921e04a81231e74fc062f229f76a733 /dev-python/scikit-build
parentb3f2504c1d05b5999b74b2135860fc721e3adf68 (diff)
gentoo auto-resync : 15:07:2022 - 13:42:19
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest3
-rw-r--r--dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch11
-rw-r--r--dev-python/scikit-build/scikit-build-0.14.1.ebuild68
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index 78db9a1fa9ae..cf143faa66ae 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,6 +1,3 @@
-AUX scikit-build-0.12.0-tests-no-coverage.patch 270 BLAKE2B d7cba4096ffb66c98837da997024ee87bb3fd878a6492fbd63088aab294048e700652a82cd3e27bb8e55ea5fdeeda4240971a32b6c7644f2c51ab7c42da1abea SHA512 f52a6096a4840baa743b90296b98f55963c13990ce795cb0ff9ad11256196d9d5164d3118bb48e8e10779e55f2341309de71a3ee47cbde326280de0064f1b21a
-DIST scikit-build-0.14.1.tar.gz 266776 BLAKE2B cb674412ef000fa961b85b32bf7759430cc5ff1b175e29017219ae3b941bfefee5760742cf17549fe7868fa0fc80f72e027aa683cd07bec53c1578e27b1ea0a7 SHA512 c9c3caaab969e83739cb3be718fc7190ef25372fbbf689ea84f9b9725bfc8329640c26038d875ecf3ccdbab0637ef77d6a30c05dcdaaecf441f631c8601d3b63
DIST scikit-build-0.15.0.tar.gz 268691 BLAKE2B f4cb51ee2367bd4ba6f6c1cada15e1e6be731998a914b28edcf703c5a92c409b78b17dddf04a29b24d40f249ffa06eb9d05d36dc30c0e62ee001519c3ca03f58 SHA512 4d9b1d06d48708ff4f2f5fa8c8f264c7ca85946d5842a1254930d9449d6b6386c17392473c3c85147f6573f7256c94c927962cb56fa23a90a5b442de8de8d727
-EBUILD scikit-build-0.14.1.ebuild 1970 BLAKE2B 750f8acada7df5e61e813d39555fd50594dddaa8fa537ed79508f7f15ae72a2fd4f4f7256f8418ea91a6b6387d9f9f6f5de6e627c30b8c930ff2a00f9d98e11a SHA512 61b7b7e34e41a0ac06ee998afdf64833eadfcbe6a93d2dde6bb7eefb58584957314730cd701834c78e5ba30ba1a6d227edcc9ba3043b1f312933dcaff72a8cfc
EBUILD scikit-build-0.15.0.ebuild 2063 BLAKE2B 25ef4b651a08a739158ee51d7d8d5b3e3b19577e6c4e16247c16dfda2da4e951763c413835f7b10eb6cc5f864374bb2ebd9aeb062ce002b52c0992e53f3bd1b5 SHA512 4dd56b2946b1a5063f18a2b80d2a81331edfce743e2dd6a88909046751ca9001782b84c21278828a47d7ae06db1617e79e6d6e0ba745ee262cbde87fb97bd0cb
MISC metadata.xml 408 BLAKE2B 4cdf98a2ac7e4bd6e1276e0ceadb3ac7849a81c5a9931b1ea5b3087cd7ced5072c390f1b77791732a3470f2cfba6a0537732f3632a156887d7c4046235062d3a SHA512 deb17b2d33bab0a1f713edd2e10b643b8801b3c04b142dd37530d5335bfde5be6e8ffb99177170a8c24380c2958164bec95db50538993fdb681aa1d0408ebf3e
diff --git a/dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch b/dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch
deleted file mode 100644
index 993258961f35..000000000000
--- a/dev-python/scikit-build/files/scikit-build-0.12.0-tests-no-coverage.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -10,7 +10,7 @@
-
- [tool:pytest]
- testpaths = tests
--addopts = -v --cov --cov-report xml -ra --strict-markers --showlocals --color=yes
-+addopts = -v -ra --strict-markers --showlocals --color=yes
- markers =
- fortran: fortran testing
-
diff --git a/dev-python/scikit-build/scikit-build-0.14.1.ebuild b/dev-python/scikit-build/scikit-build-0.14.1.ebuild
deleted file mode 100644
index 51a4443468d2..000000000000
--- a/dev-python/scikit-build/scikit-build-0.14.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build/
- https://pypi.org/project/scikit-build/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-src_prepare() {
- # not packaged
- sed -i -e '/cmakedomain/d' docs/conf.py || die
- # no pytest-cov
- sed -i -e '/addopts =/d' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local deselect=(
- # sandbox violations
- tests/test_hello_cpp.py::test_hello_develop
- tests/test_issue274_support_default_package_dir.py
- tests/test_issue274_support_one_package_without_package_dir.py
- tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
- tests/test_pep518.py
- # This fails because of additional item setup.py in sources
- tests/test_include_exclude_data.py::test_hello_sdist
- tests/test_include_exclude_data.py::test_hello_sdist_with_base
- tests/test_issue401_sdist_with_symlinks.py::test_sdist_with_symlinks
- tests/test_manifest_in.py::test_manifest_in_sdist
- )
- epytest ${deselect[@]/#/--deselect }
-}