summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-24 00:11:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-24 00:11:52 +0100
commit67e5603b2844a6657dd0438fa26626b013e5567f (patch)
treee7319631fdf1c41ddbe888e89a717d1ba42af992 /dev-python/scikit-build
parentbff543bb632933380da922cbfc07c67157d72d42 (diff)
gentoo auto-resync : 24:06:2024 - 00:11:52
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest2
-rw-r--r--dev-python/scikit-build/scikit-build-0.18.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index 4edd8ef13549..cbcc31aae2a6 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,4 +1,6 @@
AUX scikit-build-0.17.6-setuptools-69.3.patch 6448 BLAKE2B d7a964b05468da5d81d08435c1c6d38b1096814693d27c9eb6467dab1809ff63b79a778b4ba07ac357d4128549a5318b312aec1d6f1c702a8fca4e1ddc189579 SHA512 6bb096d4b4c6d451d4c1ef1f4792a8e72e624cbcff5219bb7d4eed1459454c9618bb3bb9a03c39c7ef79f9fa0054ca337da3a1c4ed4cdcc007b8d054f20fbdbb
DIST scikit_build-0.17.6.tar.gz 272208 BLAKE2B 9e3f908041eca89182f798c54a1a248934dc026816f7cd041a8debc97be27096942dda42a0ae63e87b9337304a478d6f520edcd5ea7a45aae6a195d1f769eed2 SHA512 92b97146f40d8222bd8415ef8439497d5075b72e5bafc40aba0a3e2911d269a118f2f7d41f468f7add8949f550b1fd7d5a9113d249e42dfac431108182ca9198
+DIST scikit_build-0.18.0.tar.gz 273824 BLAKE2B 2eac991ea22948e900c4485783f5bcbb8b87bd5858bbe7ade99b2a67c16a9a035e04c53b2d9b94422a5eff36f33c11cf297198bce520ba818b7355386977a8a1 SHA512 a374f86c69a288ddcfe8e8d95b594b2bf94365b4d6d4d25a7912cf871f12dfb1866b1d74694c919ef8e4fef3d166b7afe9de3b32b56add33173840a9bb917c71
EBUILD scikit-build-0.17.6.ebuild 1953 BLAKE2B 507c00500aeac432556d057175eb7333e4a3f3e4a04b16051ac72be9f3fdb502535e94f285ccf54bd29461ef54d968fe06ae7e9af33f761914548b814df9e72a SHA512 3bdfe867cb6b1c36fdc4bd5cf75fcf75b6c87b430a72a4ed0dbcddbbdf4d2e2703b42d43650827244250073502918fbb6bc042f2e7d354f09e01ee85fa16c3a2
+EBUILD scikit-build-0.18.0.ebuild 1872 BLAKE2B 0d39b7adff8535c4db10e4e95f29d33d571947bbd8dcc0e67bb8d7f4c5bce346700f1e1f9be8de88182edba032d13ddb5ea0a240bb6bac1fdca6271cd51b3af1 SHA512 e76de4521524734f8c7ddfbc25b1ddd46ed13b997b972b0a588a8f86ff334cff6c9850fd8050a7dac21b5f256d6b21ebc198eb0b15e90fcb9f2f486fb928d661
MISC metadata.xml 473 BLAKE2B 9d02a79439618fa413f74e4a617b8af042879be7a44c8f1c33e254e985d4f24057321fb2ec0b73074be1f6b67af3984190e48669e19985d6297411c0c5b61a79 SHA512 afc398c6287ce67eb85402832684fd006385e70d28a738ca8c5f1e2d008526621121cd9107a7fbc217a1a5857b54fa1dce3de69c47db58fc76990764b814a36d
diff --git a/dev-python/scikit-build/scikit-build-0.18.0.ebuild b/dev-python/scikit-build/scikit-build-0.18.0.ebuild
new file mode 100644
index 000000000000..962a821c1d62
--- /dev/null
+++ b/dev-python/scikit-build/scikit-build-0.18.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build/
+ https://pypi.org/project/scikit-build/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-42.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/build-0.7[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.25.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.10.4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+# note: tests are unstable with xdist
+distutils_enable_tests pytest
+
+src_prepare() {
+ # not packaged
+ sed -i -e '/cmakedomain/d' docs/conf.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # no "library" in (our install of) pypy3
+ tests/test_cmaker.py::test_get_python_library
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock \
+ -m "not isolated and not nosetuptoolsscm" \
+ -o tmp_path_retention_count=1
+ rm -r "${BUILD_DIR}/install$(python_get_sitedir)"/{easy-install.pth,*.egg,*.egg-link} || die
+}