summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 23:41:21 +0000
commit374561aeaff53ce5a2836af934749923b4ea3763 (patch)
tree66880cb44879bf28002f361a4c862814df616b8f /dev-python/scikit-build
parentea0515fa73da4755b498bdb18bd7fd7a13e616cf (diff)
gentoo auto-resync : 20:01:2023 - 23:41:20
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest2
-rw-r--r--dev-python/scikit-build/scikit-build-0.16.6.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index c444c7bf7133..a52833a9d66f 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,5 +1,7 @@
DIST scikit-build-0.16.4.tar.gz 271037 BLAKE2B 6cca8a3c4f4b37228b77ac098650a5eca4ad0f525ca7dcba178f4cffabb7e60e9a7bbba244e64c1a598ab5916f2f47788198eb2a19803d8d0cf7b9792f4e06e2 SHA512 90315ceac4c372e4d7248b4b56b6092362c2c43fbdc180d1a234e057209c508a05d2c6e0a3d0c2587c3adb8957e4c66d5c171a2a2bc3dbf9874a0de58d97d976
DIST scikit-build-0.16.5.tar.gz 271974 BLAKE2B e34d44fb27975720adc4ca57a0fabc9b05260a13043b546d19bfb44fa1c60e6490c5d7bbd41494481da470e24c05c4da3eb41b26c78160a35be1e3c29f9a4ef4 SHA512 37e50b3a1fc04b6758b65a58f5d5239effbc0ab38a4a2024098b6a69eea1d7a9a388e41696176469e9c55a7c8b73ace9d7eee2daf5d0fbaefe2a3e09880ee600
+DIST scikit-build-0.16.6.tar.gz 272201 BLAKE2B bb14b0db52d0c04b9630fa27ccbc58c7af72eb8640c4dc82e920acdbc815e2eb8f7662684b23aa42765966ae1ad4e046dead3d7090a263d79f69bfd955ab0f24 SHA512 f36a46845420b441ca158ea05bc20023238afdf81b2108554a52a4a2be0cb19ef6b2729997199d9a9d18841c8470df8f7e7a986a86e1172328f0963f3a015f3d
EBUILD scikit-build-0.16.4.ebuild 2019 BLAKE2B 823587ca45b0567546f550799b59b389bba5233b090c7b4f315c370c130a3e3b65ca9b8cb2cb0e7288dcd9d6da947596e80b8efb655fe1d6965c0d95f0145fdc SHA512 4dc63614cc8578b028dfb83fc5b4daa556676c1e042c6ec5186474161dcb6c1c199cebba6bc40073a1c684b07984bdda30d3fa173c0340cca8534ee96f6c376e
EBUILD scikit-build-0.16.5.ebuild 2035 BLAKE2B 0eeaed66d030d918251d09a6ac2a8fa89efca4dbabc6a15925d174eba23c72b50cbe4c38bb870b9374c2fcaf51669998d6ca8acddc0acecea7a940106ad0cb08 SHA512 abafbadb09c5f51b3a0f2d3912417f4f3da52a87920990b3aca275c185d148674a9b56248b2a4f0db70f6c40d309fcbab0e6db12430bec15a0c982010dac2603
+EBUILD scikit-build-0.16.6.ebuild 2035 BLAKE2B 0eeaed66d030d918251d09a6ac2a8fa89efca4dbabc6a15925d174eba23c72b50cbe4c38bb870b9374c2fcaf51669998d6ca8acddc0acecea7a940106ad0cb08 SHA512 abafbadb09c5f51b3a0f2d3912417f4f3da52a87920990b3aca275c185d148674a9b56248b2a4f0db70f6c40d309fcbab0e6db12430bec15a0c982010dac2603
MISC metadata.xml 473 BLAKE2B 9d02a79439618fa413f74e4a617b8af042879be7a44c8f1c33e254e985d4f24057321fb2ec0b73074be1f6b67af3984190e48669e19985d6297411c0c5b61a79 SHA512 afc398c6287ce67eb85402832684fd006385e70d28a738ca8c5f1e2d008526621121cd9107a7fbc217a1a5857b54fa1dce3de69c47db58fc76990764b814a36d
diff --git a/dev-python/scikit-build/scikit-build-0.16.6.ebuild b/dev-python/scikit-build/scikit-build-0.16.6.ebuild
new file mode 100644
index 000000000000..9be654a86be5
--- /dev/null
+++ b/dev-python/scikit-build/scikit-build-0.16.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build/
+ https://pypi.org/project/scikit-build/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-42.0.0[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/cython-0.25.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.10.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-virtualenv-1.2.5[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+src_prepare() {
+ # not packaged
+ sed -i -e '/cmakedomain/d' docs/conf.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # sandbox violations
+ tests/test_hello_cpp.py::test_hello_develop
+ tests/test_issue274_support_default_package_dir.py
+ tests/test_issue274_support_one_package_without_package_dir.py
+ tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
+ tests/test_pep518.py
+ # This fails because of additional item setup.py in sources
+ tests/test_include_exclude_data.py::test_hello_sdist
+ tests/test_include_exclude_data.py::test_hello_sdist_with_base
+ tests/test_issue401_sdist_with_symlinks.py::test_sdist_with_symlinks
+ tests/test_manifest_in.py::test_manifest_in_sdist
+ # Wants internet to install things with pip
+ tests/test_numpy.py::test_pep518_findpython
+ # TODO
+ "tests/test_command_line.py::test_hide_listing[True-bdist_wheel]"
+ )
+ epytest
+}