summaryrefslogtreecommitdiff
path: root/dev-python/schema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/schema
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/schema')
-rw-r--r--dev-python/schema/Manifest3
-rw-r--r--dev-python/schema/metadata.xml12
-rw-r--r--dev-python/schema/schema-0.6.6.ebuild21
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/schema/Manifest b/dev-python/schema/Manifest
new file mode 100644
index 000000000000..a58073f66e7a
--- /dev/null
+++ b/dev-python/schema/Manifest
@@ -0,0 +1,3 @@
+DIST schema-0.6.6.tar.gz 13490 BLAKE2B 6398aa3883a7bc8334a10a3a930c49647d58c3a6e5d1adbd8ae7cd48d0cc58469e7b5879202aa877c1ddc09219eefce679a88dac56f2ffd09e8610ac3b280763 SHA512 1a0729b30eb3190396401f1d8b7976119e11acaf2e1902a05e5a8239337004bc0a416939f0b1212dbe16304bfb0c1e28051752c2a81bfd0f14899ef76a166bb6
+EBUILD schema-0.6.6.ebuild 567 BLAKE2B f2b91c007dc0a51b28b4f2dac0bb88891e7adc8277127c4d94d31a1706e7758ea456a96335d0486e186da127379943321d3a79538e2c87064396fcb5855f7a83 SHA512 ece96f44248cedf0141595a5c5cbe9a33077ae865bb101af0cec3efea7df56a2769833a7c2261e19e78e54287906c99d972d19b1f5072b3370df6d3d48027c84
+MISC metadata.xml 376 BLAKE2B 6f93639c72207a159fbbb7280beb8ddef39dd545d06b9e2f0c8286c223033c990f808753115ab5703ef23149db31e57f05bbda679e2cb301dd6541d755b00f1a SHA512 0a27a52700fe812f2a0bf7c563caaa3eb47b02e97314dc0d7635597ce958f8898ba187c0b869722e5cfc04a4358dfb78d30383e3be2cb57f1f6becccf475961d
diff --git a/dev-python/schema/metadata.xml b/dev-python/schema/metadata.xml
new file mode 100644
index 000000000000..fba82fd7fede
--- /dev/null
+++ b/dev-python/schema/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">keleshev/schema</remote-id>
+ <remote-id type="pypi">schema</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/schema/schema-0.6.6.ebuild b/dev-python/schema/schema-0.6.6.ebuild
new file mode 100644
index 000000000000..a478507455d8
--- /dev/null
+++ b/dev-python/schema/schema-0.6.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.org/project/schema/ https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"