summaryrefslogtreecommitdiff
path: root/dev-python/scapy-python3/scapy-python3-0.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
commit343a7272d559a21a0e0ed13cb743fabb2bfcc479 (patch)
treedb03f20672a6244296ccc2aa27e70757937eb9f7 /dev-python/scapy-python3/scapy-python3-0.23.ebuild
parent456dbeaab3e2f71f527eae542ab44d1e372b0655 (diff)
gentoo resync : 11.01.2018
Diffstat (limited to 'dev-python/scapy-python3/scapy-python3-0.23.ebuild')
-rw-r--r--dev-python/scapy-python3/scapy-python3-0.23.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/scapy-python3/scapy-python3-0.23.ebuild b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
new file mode 100644
index 000000000000..9da508913c37
--- /dev/null
+++ b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+IUSE="test"
+inherit distutils-r1
+
+DESCRIPTION="Packet crafting/sending/... PCAP processing tool with python3 compatibility"
+HOMEPAGE="https://pypi.python.org/pypi/scapy-python3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !net-analyzer/scapy
+ "