summaryrefslogtreecommitdiff
path: root/dev-python/scandir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/scandir
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/scandir')
-rw-r--r--dev-python/scandir/Manifest2
-rw-r--r--dev-python/scandir/scandir-1.10.0-r2.ebuild8
2 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/scandir/Manifest b/dev-python/scandir/Manifest
index 8b9f1e1774b4..3991b1449e60 100644
--- a/dev-python/scandir/Manifest
+++ b/dev-python/scandir/Manifest
@@ -1,3 +1,3 @@
DIST scandir-1.10.0.tar.gz 33311 BLAKE2B 47576618c41a477ff7bab9daecf2e4719ed0c497a25fd68b4bacae073fc418f9fc51503812af726d1d124f07cccfb418ae09c196cf7ce283abf5d3bbc36b7e09 SHA512 42a570320018ffff2172ada67002334446c73c53813b36d63558d3854ded2fac0b266fcaf399cf9a735ceba110636b6901683fb26cde1e286ff476bc37e3d335
-EBUILD scandir-1.10.0-r2.ebuild 667 BLAKE2B c08e894fcb1f489c7d2db5f29fc3091a894029aba08ae0acf84df4c33d07c6c0e1b24a52fb4908af8c4b96602a3e4169ebd16b11f975312a97e92a5bc00f0ffa SHA512 e650cdc98804f1eed2b8d880f041ae3e75e737b850db819020b1c945616f672e22c303c8f57399045e16a5274fcda034b54a90a52db6f1a9384217c33011f544
+EBUILD scandir-1.10.0-r2.ebuild 581 BLAKE2B 12ae1193b329ca8de10398d504196cf5c8ebf6662f332ad996e937a59e687c9575904c9fb682bdb95f07688d6f39415dc5257a59e7418f0a70ef414b1ee10c28 SHA512 d3d736f33875711d56646639c7c47d49a0e80878a69ffae574825ce54bae04dea409a0c9499a5fc07aea7a81380b6a405eda132fab027ff6fef7f5830eddb8dd
MISC metadata.xml 495 BLAKE2B 7137cdfc395a1e80576885adb3c870ba25034a657c342b3819328f276d55ebf6d7756e57644a6ff4d45ca07cdb561078dbb1deb1b993816c7088850dee45c3bb SHA512 e762fa761b5b00288870eac3af8aed0d05efba207d83138adc873da902a7e197b710caeb87a3083e5f23436f4a2c799996fe07201195de065bd430b9c35183ee
diff --git a/dev-python/scandir/scandir-1.10.0-r2.ebuild b/dev-python/scandir/scandir-1.10.0-r2.ebuild
index 84c1093fe800..d7671f8bd5fe 100644
--- a/dev-python/scandir/scandir-1.10.0-r2.ebuild
+++ b/dev-python/scandir/scandir-1.10.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -14,11 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" test/run_tests.py -v || die "tests failed under ${EPYTHON}"
}