summaryrefslogtreecommitdiff
path: root/dev-python/sampy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sampy
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sampy')
-rw-r--r--dev-python/sampy/Manifest5
-rw-r--r--dev-python/sampy/metadata.xml16
-rw-r--r--dev-python/sampy/sampy-1.2.1.ebuild18
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sampy/Manifest b/dev-python/sampy/Manifest
new file mode 100644
index 000000000000..e0c44fa8dcaa
--- /dev/null
+++ b/dev-python/sampy/Manifest
@@ -0,0 +1,5 @@
+DIST sampy-1.2.1.tar.gz 63520 SHA256 5c8d913d95cb432c11be29ab42414f05ce13ef16a811b8118d5ff69dceb1fc67 SHA512 a531d797b1ce3539a78cdb6ea9b943adad1537ce4e151925b9ed44513fcff1de625026e2d23abc39cd326f69cf71849124395c3cc874c603ecc60ab14e188d13 WHIRLPOOL 9536e320e983ac1f7e31eb1d4de2ba60834f29dc3000b8b5dd87e70fa6881650b4c2e4cc11478b28046e2cc01974441b1310b4fae76ba550578169cb30ccdf80
+EBUILD sampy-1.2.1.ebuild 460 SHA256 ddc089fbf757408513b29ef533a06e9eb356a0145d282ce322a0f11381c83afe SHA512 d141621bcb46f6662032f74f7e11d729f8a4685a51367dae0433c1d74568acf65874968d80eca3667b0eb14bd0200e4291ef2fd46732ef081c0df1e58d7ad822 WHIRLPOOL d01cd047f43764bf17ef7853d3b25e30d68f517082ffcf8263d79dd0e8887fe0cd4c7afff0053745733be6301e52ed39c4c897454599dfccf8f06541da52b7d9
+MISC ChangeLog 2423 SHA256 187605c4681c9b1ec14c83cec4bf2318a7c9f81f8047f36489b04dfb6a18645f SHA512 3421e3442216bbfd3f55bd02fba814efe2fdd83d71fbd10f8c12b57972458d4a8aa1ff6c8be96724dbefa07131ef44f059ba21c7da5db304e9d34d4e775ec6d4 WHIRLPOOL 13bbb19d34d3a2d9ea78ffcbe45ef5b2390cfabba843a41618b516dde9cdb4ce881a923f5408ae5af2170d55ac2d8ba14702dc4d5bf9782723db927b455547b8
+MISC ChangeLog-2015 537 SHA256 8e8104cc1bb5a4b1339c53158cae4347402eba2d30ecd393a7465327719ffa17 SHA512 6dc477edbc9793b0d296f154b805f4d45ad32a4d71a4f8d875f1d5ffa3069c32d70e7ccfcefec04be144bba0212f3bf5411bc47133347f53921c044282f4b8e1 WHIRLPOOL d5f3a25e1bcf51e529cebd2b71888055a1a0a8b2539be778022d524e9f0b16d041d3297a002d407af8ca4f5486c1085d0c3295f7f9c8403761d6869e16246a9b
+MISC metadata.xml 537 SHA256 46a87dce1e4a7cfd4ce3625640198074799fe43e9eb47e499523f96b0c765556 SHA512 be34835ecfdc10e52648e3c0ce500d5d6341266b16ca8accc12f60832186f39a5ada1ca711645f52eb4c53daf8e1ccfef7eda9191aa4489ee9156311446683cd WHIRLPOOL 207bea7c390809b13ee4e81a4e8658b7f30b2b414542ac37706225ea8c1a141ecd2f781db93d4fd45577a94fe8909ed9f478ea12095349db5b6abd16278f772f
diff --git a/dev-python/sampy/metadata.xml b/dev-python/sampy/metadata.xml
new file mode 100644
index 000000000000..8b8a18adc9e4
--- /dev/null
+++ b/dev-python/sampy/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+</maintainer>
+<longdescription lang="en">
+ SAMPy is a Python implementation of the Internation Virtual
+ Astronomy Organiztion of the Simple Application
+ Messaging Protocol (with Web Profile support).
+</longdescription>
+<upstream>
+ <remote-id type="pypi">sampy</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/sampy/sampy-1.2.1.ebuild b/dev-python/sampy/sampy-1.2.1.ebuild
new file mode 100644
index 000000000000..2658fc8b64a2
--- /dev/null
+++ b/dev-python/sampy/sampy-1.2.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Application Messaging Protocol messaging system implementation in Python"
+HOMEPAGE="http://packages.python.org/sampy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""