summaryrefslogtreecommitdiff
path: root/dev-python/sabctools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
commit5c636a121a9064a4373d06b60d49a6f5d67c0e2f (patch)
tree8e5c8c582e12cb579ac94bdaafcd00282252a50d /dev-python/sabctools
parentb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (diff)
gentoo auto-resync : 25:07:2023 - 05:42:52
Diffstat (limited to 'dev-python/sabctools')
-rw-r--r--dev-python/sabctools/Manifest5
-rw-r--r--dev-python/sabctools/metadata.xml16
-rw-r--r--dev-python/sabctools/sabctools-7.0.2.ebuild39
-rw-r--r--dev-python/sabctools/sabctools-7.1.0.ebuild39
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/sabctools/Manifest b/dev-python/sabctools/Manifest
new file mode 100644
index 000000000000..9c34a199f64d
--- /dev/null
+++ b/dev-python/sabctools/Manifest
@@ -0,0 +1,5 @@
+DIST sabctools-7.0.2.gh.tar.gz 8539819 BLAKE2B 38212656c745238f106fbc9334f6dccb02bb9e05153bc73a21a783a25a0c5a63cae2893a01fcceefe37e6f5f187fc6d762fcc632f1228410e951740c808e0e9e SHA512 05968a29afb7a041549bae9e9a4303160820da4cd10ea33ab4475fe48fd0b4cf46023c6254715161265f3e1bdf2b66ae7e62007789fbc288aa229d3a218a3df8
+DIST sabctools-7.1.0.gh.tar.gz 8539861 BLAKE2B d19f46dc9d92ebd59f74b74f21129c11d425e690d9b43278cc691c41a2f85bf307775969f6bc0716ac74cd4f630971caa0896ac7c6af129bb9c58383e5afdba3 SHA512 bba1c441111aafd8b028a34637d1f9b855b7d232545bc6e56f7cc650bc22a7ee6a1ad6258aa963ef338a061adb5cd9692e1d6ea215ca7bd9fa7bf06b90079e5b
+EBUILD sabctools-7.0.2.ebuild 762 BLAKE2B cdc9333c738724772186bbe75590def51a2a660598011d20ceab3df376bc693464e365072dae643bb007a9a7d310d4af1fbb9086426847f99698598697b28749 SHA512 edb4485c2d9e69a69dfbc310a92ba498f36d8836ca93423bbb628d772d7940ab781efe4ef093cac5adf89840d5815a1bc1736a1842ad56587263d7e3e978a643
+EBUILD sabctools-7.1.0.ebuild 763 BLAKE2B d9a775d03561bc3a14b6be4f22e9a47aaec3334c3cb8dc50e70b4cc39530391850960fc5c1d66d22031443f4c64234ea0ece75dbff301f6fe59f624b0c605ae9 SHA512 e0afba13f5d81df0805072dc39a46332640b4994227668e019558aaf721a46dfdba60fd0fe84d7da22291f3c7a7dbf2fa2a0b72dbcfee5618d596091726218b6
+MISC metadata.xml 528 BLAKE2B 5dfe580ccb2a5bf9abe052dd7a11451eea49bc2182455b4feef17f927e73fb93a3402bd02f8f2cf03295170831377ac0f33f081bfed2256a0718b5d95cd43d6c SHA512 9a33e306b81242609de76aa1d99e7785e6b3d09b789bf967c0b9fd6d6ca07a00995e3dbbd27d4f63f8beee7657910a40712e255f7875d5b432c5c4fa5ace7085
diff --git a/dev-python/sabctools/metadata.xml b/dev-python/sabctools/metadata.xml
new file mode 100644
index 000000000000..5f55022d388c
--- /dev/null
+++ b/dev-python/sabctools/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sabnzbd/sabctools</remote-id>
+ <remote-id type="pypi">sabctools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sabctools/sabctools-7.0.2.ebuild b/dev-python/sabctools/sabctools-7.0.2.ebuild
new file mode 100644
index 000000000000..de4949031d0a
--- /dev/null
+++ b/dev-python/sabctools/sabctools-7.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest
diff --git a/dev-python/sabctools/sabctools-7.1.0.ebuild b/dev-python/sabctools/sabctools-7.1.0.ebuild
new file mode 100644
index 000000000000..a500ef55dcbb
--- /dev/null
+++ b/dev-python/sabctools/sabctools-7.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest