summaryrefslogtreecommitdiff
path: root/dev-python/sabctools/sabctools-8.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-29 23:38:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-29 23:38:29 +0100
commita55dc4dc2b72859e439db575f57f02ce4ba700f1 (patch)
treef1d396ba3bc3ed0d2e420132606e3b704048f22e /dev-python/sabctools/sabctools-8.0.0.ebuild
parentca2977e80c0b29d0e6ce6ff178b6e0043442262b (diff)
gentoo auto-resync : 29:09:2023 - 23:38:29
Diffstat (limited to 'dev-python/sabctools/sabctools-8.0.0.ebuild')
-rw-r--r--dev-python/sabctools/sabctools-8.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sabctools/sabctools-8.0.0.ebuild b/dev-python/sabctools/sabctools-8.0.0.ebuild
new file mode 100644
index 000000000000..a500ef55dcbb
--- /dev/null
+++ b/dev-python/sabctools/sabctools-8.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest