summaryrefslogtreecommitdiff
path: root/dev-python/s3transfer/s3transfer-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/s3transfer/s3transfer-0.3.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.3.1.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.3.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.3.1.ebuild b/dev-python/s3transfer/s3transfer-0.3.1.ebuild
deleted file mode 100644
index d81234e7f387..000000000000
--- a/dev-python/s3transfer/s3transfer-0.3.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="An Amazon S3 Transfer Manager"
-HOMEPAGE="https://github.com/boto/s3transfer"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/botocore[${PYTHON_USEDEP}]
-"
-# Pin mock to 1.3.0 if testing failures due to mock occur.
-DEPEND="
- test? (
- ${CDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_test() {
- nosetests -v tests/unit/ tests/functional/ || die "tests failed under ${EPYTHON}"
-}
-
-src_prepare() {
- default
-
- # Incompatible with recent Future version
- rm tests/unit/test_s3transfer.py || die
-}