summaryrefslogtreecommitdiff
path: root/dev-python/ruamel-yaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /dev-python/ruamel-yaml
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest2
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.22.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index b4fefe8bdaf2..7c9adc8ccba7 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,3 +1,5 @@
DIST ruamel.yaml-0.17.21.tar.xz 184612 BLAKE2B cc7e2a336d3c77a9f2d7e5d7233ceb4d15fddca3a97ec0e54427469fd24c7c63fc70b258adbad92a816d99a1f9839d41eccb9f3224e7a23884914755fa424bc9 SHA512 87f4723bfc76b1b21168852aabe4b49921f175294ac05b4e3f292f2bcf23fe6595df3e066843d193f881b274be2a7b358bd04625afef913bb0e5811efe98b761
+DIST ruamel.yaml-0.17.22.tar.xz 185000 BLAKE2B dda8163bfa52b29801d115bc64ef52c35086f186b4795df9dfcd785584e2de338ca055dbf07f3eaac548b14d338ac89bbda4e95196fd113a8fda3ecacb30bc61 SHA512 ac1af1c829c0a5dc65a66926d03b50eede405c9dafd811eae1b9567c81b6bb86b7dd91f4b7c6bf84d7c4833f8b17860dcfddaf7992241ac6673d7ffecf15466f
EBUILD ruamel-yaml-0.17.21-r2.ebuild 1416 BLAKE2B 7c5fec37a294037618a2f9d21788154fb806d6fc1575d622b7b8140f994395c4eb92be635f9f8ac11df318e37e72623ec68ecc6ac273e1961fcf99bfa88c95ba SHA512 2c2f983c303a954b217667a3c0034d14d422cb5e2473b79fe9ece4dc9e43a4f032dbeb74a6d78ef3c6d463f31f69e4ea63fd0679bfdecaf4a0c8e08267686ca2
+EBUILD ruamel-yaml-0.17.22.ebuild 1423 BLAKE2B 5e168553d3cae61fe84f729c50a299633d9a56e476676c2c762f5776c95b5173743e2a554209c3309c6baefae8abf882197f71c4e6efaa4cc5a5970c5f462b91 SHA512 999fbcc45460816f74fa1aef11b09a52221ee49b5a661381dbbdf01e067da037060e5df91a2ca62415480754c57a3f13bd75f8019bd947e4bf69b90dc7d43943
MISC metadata.xml 759 BLAKE2B ce5ec2429c5fe84587d1b5e7744055e1e8e91eae8dec780a4654cab405df46350d1c8175827351948364255b8fcd62ea234239260c01b8ce23b8db182e6514e6 SHA512 faa587083ffa9af40108e2ca9cfb7a4e2c3e19a731b39241a7ec62d6fca051ace92bcff3fa9896a343fdc196a04fe1d132bcbb7bfa3fd96401ac996b76bba4ee
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.22.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.22.ebuild
new file mode 100644
index 000000000000..255ffe55c09d
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.22.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}