summaryrefslogtreecommitdiff
path: root/dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild')
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild
deleted file mode 100644
index f87789872e5e..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- _test/test_deprecation.py::test_collections_deprecation
- )
-
- epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}