summaryrefslogtreecommitdiff
path: root/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.6.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.6.ebuild')
-rw-r--r--dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.6.ebuild b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.6.ebuild
new file mode 100644
index 000000000000..ccfa6dccc704
--- /dev/null
+++ b/dev-python/ruamel-yaml-clib/ruamel-yaml-clib-0.2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="C-based reader/scanner and emitter for dev-python/ruamel-yaml"
+HOMEPAGE="https://pypi.org/project/ruamel.yaml.clib/ https://sourceforge.net/p/ruamel-yaml-clib/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+}