summaryrefslogtreecommitdiff
path: root/dev-python/rtimulib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/rtimulib
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/rtimulib')
-rw-r--r--dev-python/rtimulib/Manifest4
-rw-r--r--dev-python/rtimulib/metadata.xml10
-rw-r--r--dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild (renamed from dev-python/rtimulib/rtimulib-7.2.1.ebuild)14
3 files changed, 19 insertions, 9 deletions
diff --git a/dev-python/rtimulib/Manifest b/dev-python/rtimulib/Manifest
index 375df9cd475d..bca136fede99 100644
--- a/dev-python/rtimulib/Manifest
+++ b/dev-python/rtimulib/Manifest
@@ -1,3 +1,3 @@
DIST RTIMULib-7.2.1.tar.gz 915114 BLAKE2B 5d8a54d4b1083105c1bb3b854e8474cb81cfd5eff843422e2f66f363ae04dd9e87d4cffc8f26c2a68c4f535d77ca229bc7bb7840c59ba3c6d2d45d5ee7f31987 SHA512 2a9d40f5c4db7c875fe82bd79408d97f9b00a3cd0d1be9b19baa3808b4cd260200b8ce5f5d9a6298df760aaca10555eb317d4a2431cd1c07a1b7953448852b23
-EBUILD rtimulib-7.2.1.ebuild 558 BLAKE2B 0e1b995d028518df120d6f9eacc893da35060adc102094923fa7070e53c0107b98bd3813d1f1bf4a6afac8f4276f88b5b94874a93c0caf8ef2db49517827d053 SHA512 0b3d30d6bbfe76f15c117b8153dca305b2e6f2137bcae4d087c2e8797eef7fabff74fd8db9bd2631825ba2451d1a112e2655633842775a59d775464fb42780fd
-MISC metadata.xml 369 BLAKE2B 99bc89ce5469bce6e867ce73fa66fee3fa41bf2166453c3606b03b1f3879f837c46d41068430e217a7ab4b0d0096650762095ffe5f13382ab055e5815f90ebb1 SHA512 5d49b66d13a6055421fc9e9a180d6d5657e367cfdc6e74a13c16955cc1bfda765605f0ab7c0d7d5f67ce847e09306fef52a2fb621eccdf358e5d21e82129a2b3
+EBUILD rtimulib-7.2.1-r1.ebuild 576 BLAKE2B 19b05ae328191a093d0fac7116fa17d5f9ab05abbe1305819cb84c65c2c5e2fe2a5d7c7d020bdf5f7c3d252675fa92e57110fae092907f228582d35fd5f50998 SHA512 7a31291f796050843a3ef12a2a7bfbcc3f8d7e09902874365ec7cee64537732552f01a9d849ec5ee13d2113a6f660239230e609576c95ca19e9caecbf798ea97
+MISC metadata.xml 848 BLAKE2B 8a0045ba1eb894fd8b3796e1e301e6bc11510a78f9ce3943309448f5235b0bb8865bed7d81b5da7f5dffdbc251c1a5ce908a5448d109e7e61ab433d234dca868 SHA512 1f5e646966e092c296948894357743d5be29e23e1abead62a748ec3d8237025d212bd48b9b5a15eecfbd486b02bda4e81c5ff2fee4eb08c0ef0d5f91b47e0a3c
diff --git a/dev-python/rtimulib/metadata.xml b/dev-python/rtimulib/metadata.xml
index 54d5423c4060..f9570ce600ab 100644
--- a/dev-python/rtimulib/metadata.xml
+++ b/dev-python/rtimulib/metadata.xml
@@ -9,4 +9,14 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <longdescription>
+ RTIMULib is the simplest way to connect a 9-dof, 10-dof or 11-dof IMU
+ to an embedded Linux system and obtain Kalman-filtered quaternion or
+ Euler angle pose data. Basically, two simple funtion calls
+ (IMUInit() and IMURead()) are pretty much all that's needed to integrate RTIMULib.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/RPi-Distro/RTIMULib/issues</bugs-to>
+ <remote-id type="github">RPi-Distro/RTIMULib</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/rtimulib/rtimulib-7.2.1.ebuild b/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild
index 06ba1a373675..b593b7430083 100644
--- a/dev-python/rtimulib/rtimulib-7.2.1.ebuild
+++ b/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+MY_PN="RTIMULib"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
-MY_P="RTIMULib-${PV}"
-
DESCRIPTION="Python Binding for RTIMULib, a versatile IMU library"
HOMEPAGE="https://github.com/RPi-Distro/RTIMULib"
-SRC_URI="https://github.com/RPi-Distro/RTIMULib/archive/V${PV}.tar.gz -> ${MY_P}.tar.gz"
+SRC_URI="https://github.com/RPi-Distro/${MY_PN}/archive/V${PV}.tar.gz -> ${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}/Linux/python"