summaryrefslogtreecommitdiff
path: root/dev-python/rtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rtgraph
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rtgraph')
-rw-r--r--dev-python/rtgraph/Manifest3
-rw-r--r--dev-python/rtgraph/metadata.xml8
-rw-r--r--dev-python/rtgraph/rtgraph-0.70-r1.ebuild32
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/rtgraph/Manifest b/dev-python/rtgraph/Manifest
new file mode 100644
index 000000000000..ad8cef604593
--- /dev/null
+++ b/dev-python/rtgraph/Manifest
@@ -0,0 +1,3 @@
+DIST rtgraph-0.70.tar.gz 16141 BLAKE2B dbcb4449842507e14fc45c6ad69f98564d3f826027d31644ccf13ac938796fdf2c09a2ec71668bcc908cd7180c35fa66090473df8e78bd27d7468f4ec24bf873 SHA512 73d226ba09a658f6957fa82e4956de967ef7b02ca08ac1e33a16c1c0ffe1426afef35e7c720342524c6389e42d994db9ff3404d413ddec5168980e2e1982ea34
+EBUILD rtgraph-0.70-r1.ebuild 846 BLAKE2B 421bb565f8a0b60899de4e64c5328139e9faa369299312f17fcf91d9baab7848196825a6bbbaea6330602c79e327f6dbc9f9ff29ba76e430fa9137b6dc369a8a SHA512 9dbb6e27861accc493a85a53f6c10031706d1ffa726ef0af2aa67d97988f537e9baa9662596decfce97aff2dd25f6d5baadbd86542e3179a650ec05cc90bbe60
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/rtgraph/metadata.xml b/dev-python/rtgraph/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/rtgraph/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/rtgraph/rtgraph-0.70-r1.ebuild b/dev-python/rtgraph/rtgraph-0.70-r1.ebuild
new file mode 100644
index 000000000000..2b082cbc1d23
--- /dev/null
+++ b/dev-python/rtgraph/rtgraph-0.70-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Widgets for graphing data in real-time using PyGTK, and UI components for controlling the graphs"
+HOMEPAGE="http://rtgraph.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rtgraph/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/pygtk:2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv ./{cpu_meter.py,graph_ui.py,isometric_graph.py,line_graph.py,polar_graph.py,tweak_graph.py} examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}