summaryrefslogtreecommitdiff
path: root/dev-python/rsa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 02:37:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 02:37:55 +0100
commitb5c8e7977a8950fe976559fbed28db9c0bcd3d6f (patch)
treef3685b9d72ea7daa9be01003ad1168de69152385 /dev-python/rsa
parente26a7b5ef1fe42a66a3c91fe878da93c7cf83737 (diff)
gentoo auto-resync : 19:07:2022 - 02:37:54
Diffstat (limited to 'dev-python/rsa')
-rw-r--r--dev-python/rsa/Manifest3
-rw-r--r--dev-python/rsa/files/rsa-4.8-includes.patch28
-rw-r--r--dev-python/rsa/rsa-4.8-r2.ebuild (renamed from dev-python/rsa/rsa-4.8-r1.ebuild)2
3 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/rsa/Manifest b/dev-python/rsa/Manifest
index 34a7162b1bfe..1a351fe7a249 100644
--- a/dev-python/rsa/Manifest
+++ b/dev-python/rsa/Manifest
@@ -1,3 +1,4 @@
+AUX rsa-4.8-includes.patch 1057 BLAKE2B b72159300e46fee904fb715083dab39e9ade88e68e1d6906968a79e0e86278632b94700b6e09dfb4994b92704c50e71634b2eefe6e017a1bf98aaa7cb73956bf SHA512 5366f1afcad0d60f3927a449c4f31d792bf7b1432a81bdd9e71b0e6b4bbedc9ecb3d4f1e39afb9c28f5903f9afe5f0c3002f208a06b034623d2c5ecb1d37dccb
DIST python-rsa-version-4.8.gh.tar.gz 73634 BLAKE2B 55f25b6747f4f0bad12cbbb75c6e6fdbe6f913265866f11430644b46f9d3a2f615e6ed460d04cc732cfe29f0a4e47b14f2581f29d523b3018272ef976a6a04aa SHA512 d65e5d3c902508f4ea7424099471cd68568b052b9647a87ceb155ecc444ba6a8bd0ebef6fe1bf38720a19193cd494a8b64f744cca5812d1a3bec28f3fa3a9a3d
-EBUILD rsa-4.8-r1.ebuild 767 BLAKE2B 5181c8381bfba94610bd72f4ddfebcbd593cafcc98f60f3d57f6efff757b7e51935e8501f41da60d6f2b4521a2cbbe60707e9f0fd6721ed22cb2eacce94890a3 SHA512 89fc7151041c3524914bc56b69cf18a5706c3d60f17326b3ca62d3eb4923cec942a236d64ade37a79a3395a7cc4c5fe6ed46c7a1d73fa7ab698d911ca8e7edf3
+EBUILD rsa-4.8-r2.ebuild 814 BLAKE2B e6dc62336c2f52a94c0ba07e733bb6a544115562c082655a6689e5a8007b02dbd540f9dd325a103e63f9f29a886ae42c7c7cd471dfc9e74e1cc37d0137c3eb3a SHA512 f9f145e9ff3502efb1586d0cb2ab67f642105602dc4f8ca65a7857b784e1239f66cb7ea888e4b50bc75ea16d89893534fdf66dd54fda6db2e7e8947893190202
MISC metadata.xml 407 BLAKE2B 11c7f12e753a502ea5b508e0ca88f824819c3a2dbfbaec31532fbbe9bfdbda5c75ad853b14945a3f5baa4b1eb01a0c9526d3957eed0a573bd63ac792b93bc5da SHA512 df4960d9d61726ae45490adc1d682780539bf7f053a6db9af97e453261f1866a3e8ccb956c5c769b115e90ef3c336654a85114eac1b1256dab95fed7bdb88961
diff --git a/dev-python/rsa/files/rsa-4.8-includes.patch b/dev-python/rsa/files/rsa-4.8-includes.patch
new file mode 100644
index 000000000000..181fd638d0de
--- /dev/null
+++ b/dev-python/rsa/files/rsa-4.8-includes.patch
@@ -0,0 +1,28 @@
+https://github.com/sybrenstuvel/python-rsa/commit/3031bf5c6ae64083431e849903b0104d2cfae893
+https://bugs.gentoo.org/859175
+
+From 3031bf5c6ae64083431e849903b0104d2cfae893 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 27 Jan 2022 10:26:23 +0100
+Subject: [PATCH] Do not include arbitrary files in wheel
+
+Fix the include key to apply to sdist format only. Otherwise, the
+listed files are added to the top directory of wheel as well and end up
+being installed in top-level site-packages directory, e.g.:
+
+ * FILES:+usr/lib/python3.9/site-packages/CHANGELOG.md
+ * FILES:+usr/lib/python3.9/site-packages/LICENSE
+ * FILES:+usr/lib/python3.9/site-packages/README.md
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -26,7 +26,9 @@ classifiers = [
+ "Topic :: Security :: Cryptography",
+ ]
+ include = [
+- "LICENSE", "README.md", "CHANGELOG.md",
++ { path = "LICENSE", format = "sdist" },
++ { path = "README.md", format = "sdist" },
++ { path = "CHANGELOG.md", format = "sdist" },
+ ]
+
+ [tool.poetry.dependencies]
diff --git a/dev-python/rsa/rsa-4.8-r1.ebuild b/dev-python/rsa/rsa-4.8-r2.ebuild
index fffb3c5c50ad..5a4cdf383088 100644
--- a/dev-python/rsa/rsa-4.8-r1.ebuild
+++ b/dev-python/rsa/rsa-4.8-r2.ebuild
@@ -29,6 +29,8 @@ RDEPEND="
>=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
"
+PATCHES=( "${FILESDIR}/${P}-includes.patch" )
+
distutils_enable_tests unittest
src_prepare() {