summaryrefslogtreecommitdiff
path: root/dev-python/rq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
commitbd35a61d88b111f25f4b10126e0d4755545fc7a5 (patch)
tree656ac661ed7b28ad66ba778b74bc5fe4e2b86b10 /dev-python/rq
parent5d4291ee2ba8b85e8515b5f47b814a5c872eed04 (diff)
gentoo auto-resync : 29:10:2024 - 03:04:53HEADmaster
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest2
-rw-r--r--dev-python/rq/rq-2.0.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 6e56ca4beadb..399f0146d604 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,3 +1,5 @@
DIST rq-1.16.2.tar.gz 629881 BLAKE2B 69ac4ba43ea79ddf998bc9f7cf0fc5fa42acb0315dff663b1c924498ccfabdd37ac6d9613e128b838b9e1f45988632a337fb2fa50f5adcd1b69aa520b5ad33e2 SHA512 1c3162b1acffc9d11292fcbff7177267272a02e752b5839a4004b875bb5bb25af7e61f31041df438ef4e0e47152296c3a2711856c6a36d787848dcb766387d1a
+DIST rq-2.0.0.tar.gz 639193 BLAKE2B ec44a45618f4ba0cafd30d13d15db8efc26c35f41100019e94d28ac21ca0c6157df34c55fd9bc2c2afdd4752e815a45150c95840339744c005c297153795e598 SHA512 46878626ad939fdc3f31bfd04fab9d11f266a390fe75ea22fde62e1622607e715673a8f3d2e3aba78e489b861d16068836aea4eca5a88cd295d6b6ca61707a41
EBUILD rq-1.16.2.ebuild 1472 BLAKE2B 5069ef150732873a25c3d4f73e8c699e267dc28d2cc304afcb6f9aeda696fb08503fa3b3e1a12ef6cbe3da0d0fda9b597f15487c3b0b7f7eb6cc51bff0953fc4 SHA512 33dc640b0aced4501582d728d3ad977bf7f406c6f09b06d22e3ef00b121a6ea84f2b5e678c72c561fa67737fa12579725bda49c4b6144c391d0c02ff723ae4d2
+EBUILD rq-2.0.0.ebuild 1599 BLAKE2B 0a5a9bebfeec8cc8e73312881b9e43ce9ae7a97bdccbaa4075934d8758829f73676755ac33a47b1b0f14f9d8c4e1d8ccbcf1952272f595731a3f2aa16725b0f4 SHA512 1d31e528652b8ae8d657e89e2edaaf08c78473b4152569c244e1691d9acbdaf7ea806fc2c7f3e94baa9f258610ff4740b1ee819b1b5d76632a41cba383d6f926
MISC metadata.xml 453 BLAKE2B 6a46d43b524fded1ad4749fb9669ea07f8b3e23940d0bf2a4db5d92564316b01fdfbe220771e30b1a110ef72c613ad683cdcb7940682ea32198a5b6f027e4db3 SHA512 104ef96c34b55a9fda377c1304ff85781219fdbccef1a83d1bef30cb2fbd0ef816cfe82715af8937f452499135f7ed65c65a29c34919a09b6144ada367c26af5
diff --git a/dev-python/rq/rq-2.0.0.ebuild b/dev-python/rq/rq-2.0.0.ebuild
new file mode 100644
index 000000000000..5cde9ca9c756
--- /dev/null
+++ b/dev-python/rq/rq-2.0.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unnecessary typechecking deps
+ sed -i -e '/types-/d' pyproject.toml || die
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires <sentry-sdk-2
+ tests/test_sentry.py::TestSentry::test_failure_capture
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}