summaryrefslogtreecommitdiff
path: root/dev-python/rpyc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/rpyc
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest2
-rw-r--r--dev-python/rpyc/rpyc-5.1.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 2e8162722337..b1baa8b4ef6e 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,3 +1,5 @@
DIST rpyc-5.0.1.tar.gz 1258657 BLAKE2B 84d0bee67004928c26a1765a26267e3e8eb5dc09a8fd53c1d75ca691cf313a7563398626b7e89a8893415294721623206204784da01444708edb56aec8101719 SHA512 57b0d6b2dba33c7f6c9d204b4deae8ab08ed56e5799aa2c7ae4bcb8ab98486055090e3079d8b0d615fcd517111a6e02893dff85607aaca5497ae76429abe3148
+DIST rpyc-5.1.0.tar.gz 1260651 BLAKE2B 4be17e5de4b0475cd63b99bf20e55e3221149f974b9efec638e0387d71815a5a2e4ea782578152690e019e7b8a4ece17405eed6626578a9c9e379d0f4b589008 SHA512 e9783392f423abca6b488dff5be36dae066980004bd221ca5a1c451f0f9dc7e1daf749650106802f9159de619a8d5e2cd6dc90e9a5f49d16f01bbedd59b504cf
EBUILD rpyc-5.0.1.ebuild 1641 BLAKE2B 47e8397bba1ad5cfa3a673411f279690f495cf45c3b85d728d21b8f437ee533376d58543835ba89398e505b1686e5e9c3826e80722539021a7c0454947b29ff8 SHA512 73b40edd8bc5683efd9a6ff31fa49fda929bb0171ec91d765166317184bf5a4c124716b04030a816b00ba6fe16c000310f94e4e7c75949ebbcf9f05a887e2220
+EBUILD rpyc-5.1.0.ebuild 1743 BLAKE2B 65a34e082274af61faba254f133dc7c749ab71dcbd27201d299249bbf873e55707e819d5c7954336c958e47654fbdac9ada79b9010c696a3bc1c931f5b456f29 SHA512 13120fdfb51f2b62ee6ff0725739e3e250053fa35220d2e9bb58db62eec6b4a37e6948175272b4a2db30af87a25e4b5392f4cc27ca480f4796cb2def918ff879
MISC metadata.xml 654 BLAKE2B f84ea5b5fb66c2661bdcbed8566a77c872b6f1b3a6b0cb021269657b21fd414e70edf03f205ee2038d9d83a20e25d32b15760d915b98066aa7fe1a4cfeb3bd16 SHA512 6ea40af97501443c8d4ae783137bb9547c5a4cc3685c01b9d684691d110f67eb43056acfcebcc510c06fc40ff596ad9e3e30cf76cb07807f23250721e93b4954
diff --git a/dev-python/rpyc/rpyc-5.1.0.ebuild b/dev-python/rpyc/rpyc-5.1.0.ebuild
new file mode 100644
index 000000000000..9e44ad9daed5
--- /dev/null
+++ b/dev-python/rpyc/rpyc-5.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
+ https://pypi.org/project/rpyc/
+ https://github.com/tomerfiliba-org/rpyc"
+SRC_URI="https://github.com/tomerfiliba-org/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# USE flags gdb, numpy are used *only* to run tests depending on these packages
+IUSE="test numpy gdb"
+RESTRICT="!test? ( test )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
+ gdb? ( sys-devel/gdb )"
+
+RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+
+ # Windows specific test
+ rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
+
+ # These tests require running sshd
+ rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
+
+ # This test requires internet access
+ rm tests/test_registry.py || die "rm test_registry.py failed"
+
+ # This test fails with NO_CIPHERS_AVAILABLE
+ rm tests/test_ssl.py || die "rm test_ssl.py failed"
+
+ if ! use numpy
+ then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
+ fi
+
+ if ! use gdb
+ then rm tests/test_gdb.py || die "rm test_gdb.py failed"
+ fi
+}
+
+python_test() {
+ # for some reason, when tests are run via pytest or nose, some of them hung
+ pushd tests > /dev/null || die "pushd tests failed"
+ for x in test_*.py
+ do ${PYTHON} ${x} || die "${x} failed"
+ done
+ popd > /dev/null
+}