summaryrefslogtreecommitdiff
path: root/dev-python/rpyc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
commitb18dbdc69b2be6f0ac0db668b0bc57fb6f766afc (patch)
treee77939b82c93b9689bc1bb0bc8a55132c509cb44 /dev-python/rpyc
parent97f40b36b1afa9726e32962d11f3ac2d0bc5792e (diff)
gentoo auto-resync : 16:02:2023 - 14:04:41
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest3
-rw-r--r--dev-python/rpyc/files/rpyc-5.3.0-no-gevent.patch34
-rw-r--r--dev-python/rpyc/rpyc-5.3.0.ebuild69
3 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 06869e5654f4..4b75b3ce04bd 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,3 +1,6 @@
+AUX rpyc-5.3.0-no-gevent.patch 1241 BLAKE2B 44b0584b90aa4730998dd9c44430edbb0348f581b930ce1663b4dc7105c6fafccd1d73c2850892ec7898f678bc57de592dcec1af4615778919b97a15fc9d56ca SHA512 d057255548f94c433d2e6f064d9db33caf7909ae17a9eddaabb2f87560f31a6b9e94c0470b78fab7aca15c6c96b6a8c2cf96d92d57d9925d5616c7454f823326
DIST rpyc-5.2.3_p1.tar.gz 1269198 BLAKE2B 288568fcd34787850968d4e3fd9ca7c2d29e506f1331b746104760e678dfef43fd30b08f68b3bdda6df84d488f88dc76cfdd23d5a5ad0a4cefeab468ac6a1b0b SHA512 4b29899a51364779185d2b56f5d5ee4c650c40b8322e5594500222fdcec85414cdbabd41437467e2ff73124a79e8c9cde23dfe89138abb935732ccaba69de2bb
+DIST rpyc-5.3.0.gh.tar.gz 1270508 BLAKE2B c7b0c06ea7151d80d84e057b7991cbc7bcb047f24544b7669d80218f9eeb9342ba58020f608bb615dea932a1380b0afb36ba9f8e216f139ba4aadd4a7efa344d SHA512 371c60dedf3fba3232c5c1d7616a04b8cf2a8295e31b945ab51d0dee5ba5d8769062aafa860db85b951f0283b8800b61972a7f2f7fa3cc69929c7563e74be1ee
EBUILD rpyc-5.2.3_p1.ebuild 1941 BLAKE2B bf3b7774a7d13969a9374e01afc0bdfec13aa97fd44194346e5d642b54c25adfc1a9c6aad636987bd1debd53c174ece495ec76625762979c20629cc2e8745995 SHA512 992264055902d6cc93351ff500f88272c447c527bc4a35aff00c66e0047625aee2343458b3798b0d3bfd53bd2e43c426457873300ef39689a93500e8a152e726
+EBUILD rpyc-5.3.0.ebuild 2044 BLAKE2B 966a314ad2d6667837a8795534d20efbcc7cd31a7130e9b51fceea2ac2595e67aa527721c4f7dd62e790c80a35454ac99ec7289bfc689d3f890160b41f968a3b SHA512 d8423e252324df086342a16e0561dae053c197cc71b131f4efa769a9b3f78ae1af8c5d8b566064e6a70ba4902344a645a2da1c6768bea87f76c5851144c375b2
MISC metadata.xml 654 BLAKE2B f84ea5b5fb66c2661bdcbed8566a77c872b6f1b3a6b0cb021269657b21fd414e70edf03f205ee2038d9d83a20e25d32b15760d915b98066aa7fe1a4cfeb3bd16 SHA512 6ea40af97501443c8d4ae783137bb9547c5a4cc3685c01b9d684691d110f67eb43056acfcebcc510c06fc40ff596ad9e3e30cf76cb07807f23250721e93b4954
diff --git a/dev-python/rpyc/files/rpyc-5.3.0-no-gevent.patch b/dev-python/rpyc/files/rpyc-5.3.0-no-gevent.patch
new file mode 100644
index 000000000000..026741dec361
--- /dev/null
+++ b/dev-python/rpyc/files/rpyc-5.3.0-no-gevent.patch
@@ -0,0 +1,34 @@
+diff -U3 -r rpyc-5.3.0.orig/rpyc/utils/server.py rpyc-5.3.0/rpyc/utils/server.py
+--- rpyc-5.3.0.orig/rpyc/utils/server.py 2022-11-26 13:09:01.000000000 +0700
++++ rpyc-5.3.0/rpyc/utils/server.py 2023-02-16 16:15:14.153086884 +0700
+@@ -19,7 +19,7 @@
+ from rpyc.lib import safe_import, spawn, spawn_waitready
+ from rpyc.lib.compat import poll, get_exc_errno
+ signal = safe_import("signal")
+-gevent = safe_import("gevent")
++# gevent = safe_import("gevent")
+
+
+ class Server(object):
+@@ -559,13 +559,13 @@
+ self.clients.discard(sock)
+
+
+-class GeventServer(Server):
++# class GeventServer(Server):
+
+- """gevent based Server. Requires using ``gevent.monkey.patch_all()``."""
++# """gevent based Server. Requires using ``gevent.monkey.patch_all()``."""
+
+- def _register(self):
+- if self.auto_register:
+- gevent.spawn(self._bg_register)
++# def _register(self):
++# if self.auto_register:
++# gevent.spawn(self._bg_register)
+
+- def _accept_method(self, sock):
+- gevent.spawn(self._authenticate_and_serve_client, sock)
++# def _accept_method(self, sock):
++# gevent.spawn(self._authenticate_and_serve_client, sock)
+Только в rpyc-5.3.0.orig/tests: __pycache__
diff --git a/dev-python/rpyc/rpyc-5.3.0.ebuild b/dev-python/rpyc/rpyc-5.3.0.ebuild
new file mode 100644
index 000000000000..bf999d1bb527
--- /dev/null
+++ b/dev-python/rpyc/rpyc-5.3.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
+ https://pypi.org/project/rpyc/
+ https://github.com/tomerfiliba-org/rpyc"
+SRC_URI="https://github.com/tomerfiliba-org/rpyc/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# USE flags gdb, numpy are used *only* to run tests depending on these packages
+IUSE="test numpy gdb"
+RESTRICT="!test? ( test )"
+
+CDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
+ gdb? ( sys-devel/gdb )"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ dev-python/plumbum[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.3.0-no-gevent.patch )
+
+src_prepare() {
+ default
+
+ # Windows specific test
+ rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
+
+ # These tests require running sshd
+ rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
+
+ # This test requires internet access
+ rm tests/test_registry.py || die "rm test_registry.py failed"
+
+ # This test fails with NO_CIPHERS_AVAILABLE
+ rm tests/test_ssl.py || die "rm test_ssl.py failed"
+
+ # dev-python/gevent is being removed
+ rm tests/test_gevent_server.py || die "rm test_gevent_server.py failed"
+
+ if ! use numpy
+ then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
+ fi
+
+ if ! use gdb
+ then rm tests/test_gdb.py || die "rm test_gdb.py failed"
+ fi
+}
+
+python_test() {
+ # for some reason, when tests are run via pytest or nose, some of them hung
+ pushd tests > /dev/null || die "pushd tests failed"
+ for x in test_*.py
+ do PYTHONPATH="${WORKDIR}"/${P}-${EPYTHON/./_}/install/usr/lib/${EPYTHON}/site-packages ${EPYTHON} ${x} || die "${x} failed"
+ done
+ popd > /dev/null
+}