summaryrefslogtreecommitdiff
path: root/dev-python/rply
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/rply
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/rply')
-rw-r--r--dev-python/rply/Manifest2
-rw-r--r--dev-python/rply/rply-0.7.5.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rply/Manifest b/dev-python/rply/Manifest
index 802b8a414875..aacc673f9e71 100644
--- a/dev-python/rply/Manifest
+++ b/dev-python/rply/Manifest
@@ -1,3 +1,5 @@
DIST rply-0.7.4.tar.gz 27392 BLAKE2B 3604550646e083bf685a192dcf0dbc80c03cf4b97f6771ed37e228c84909c2518a58bde73ea584085351f1a2b5c865418ae671843087660d48f08e0e44e3ab2c SHA512 e3c3a828eb4b3cb20751ecb2d91efaabddbe3702d52b9adefe1748c07c843da1899e3944bcf0ab79f627ae428b8879cf99739ea7e0c6fd1acffc4ac4dee1b652
+DIST rply-0.7.5.tar.gz 27462 BLAKE2B 0f438e6fd786e7436f135da50fe90208970a0950422bb0d8e26b06cc2def964c0ebd7c3e5e3e282a1d56dbb9e804ac267095dc4da16eb57899f455d66fed2d71 SHA512 ccecc451d9e2e0fdf9df7eaaeabface782d9159cc1caf1feae6e46210f6384aa1a78c15ea3c0e9dcc0bd0d2b28e3b1328c8d37e94a8968b07ef7938e5f5ce201
EBUILD rply-0.7.4.ebuild 909 BLAKE2B 3af90c45fe36944b7fd8401ed155253106391ae20072f3c093f1f5d0549d726133518139d43c341b47cad11f63ecce4809b187ab48b132fd928a66a6f2892794 SHA512 5d2f041f82e0109ab154445b7ced7d2930a93b43bfe406f3798579690837945ce164878c056f7e46138b38432709e80d91c054a9f57ff2a4e27c1df306f79bbd
+EBUILD rply-0.7.5.ebuild 911 BLAKE2B e585cfa5e84fa34468d6bb117264aa66052286e1d1fee8e6b31c77114f9fee72670abe67c20656865903cd7e7c4d6ebec3a4dc59107892f31b46da7d1b71ad92 SHA512 26b7378fc46f52aa1cfcc16aafa3982c5c789f0e39e4352e43853fd71f73d073bac764fbd7d888be976ca916abba3105ff1e59307ba7d8f81db3406de6e37d39
MISC metadata.xml 324 BLAKE2B d6027998ac0d5aee72ca31a60c53bdf7bbc628b16eacb329041fadb5ac5c9015f152e3e9f59495505eb73a2f8fe76ccff182026b6d5c80999274268056e63e14 SHA512 9378b0e52729cd011ed824e800aa1af7ed6b9f799de0802950dbf02eeb8dd27e356ea067a46aaa91b05d96f7ec5fc17a43c0d980b7b585fecb8220b0ddc20ba8
diff --git a/dev-python/rply/rply-0.7.5.ebuild b/dev-python/rply/rply-0.7.5.ebuild
new file mode 100644
index 000000000000..cc54268d31f2
--- /dev/null
+++ b/dev-python/rply/rply-0.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python parser generator that also works with RPython"
+HOMEPAGE="https://github.com/alex/rply"
+SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ # https://github.com/alex/rply/issues/26; fail under py[3-4]
+ if python_is_python3; then
+ sed -e s':test_simple:_&:' -e s':test_empty_production:_&:' \
+ -i tests/test_parsergenerator.py
+ fi
+ distutils-r1_python_prepare
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}