summaryrefslogtreecommitdiff
path: root/dev-python/rply/rply-0.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/rply/rply-0.7.5.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rply/rply-0.7.5.ebuild')
-rw-r--r--dev-python/rply/rply-0.7.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/rply/rply-0.7.5.ebuild b/dev-python/rply/rply-0.7.5.ebuild
deleted file mode 100644
index daf24281fa56..000000000000
--- a/dev-python/rply/rply-0.7.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python parser generator that also works with RPython"
-HOMEPAGE="https://github.com/alex/rply"
-SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- test? (
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- # https://github.com/alex/rply/issues/26; fail under py[3-4]
- if python_is_python3; then
- sed -e s':test_simple:_&:' -e s':test_empty_production:_&:' \
- -i tests/test_parsergenerator.py
- fi
- distutils-r1_python_prepare
-}
-
-python_test() {
- py.test || die "Tests fail with ${EPYTHON}"
-}