summaryrefslogtreecommitdiff
path: root/dev-python/routes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/routes
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/Manifest3
-rw-r--r--dev-python/routes/routes-2.4.1-r1.ebuild5
-rw-r--r--dev-python/routes/routes-2.4.1.ebuild55
3 files changed, 5 insertions, 58 deletions
diff --git a/dev-python/routes/Manifest b/dev-python/routes/Manifest
index 49041be3291d..d1fd5cd4f71a 100644
--- a/dev-python/routes/Manifest
+++ b/dev-python/routes/Manifest
@@ -1,4 +1,3 @@
DIST Routes-2.4.1.tar.gz 182403 BLAKE2B 21a079616e1533af8fae44b0ad428b3309e5e8d1e27dddddbf3632cb3e1f5286225aec73246012a8c7c22d59d755be27f10fa09ab6ee6b34f71c6c540dfd36e4 SHA512 b0566f10ca83af0459e9c59fa2217bdc5ebf349d944396bcb21ffa731ad189c642e409381979cb5da3153630c24f20aa974a99711f16aca9f91413976af2bb04
-EBUILD routes-2.4.1-r1.ebuild 1363 BLAKE2B 50d79e759b62578127a74c5bf723c9eec878b915e4996419e35f808d2a750353a297463e16408c983b060ba7454c647a3cbcfbafad225db603817b4c7c76afdf SHA512 b1aa7a94fd8fa2a2aa9ea9f9eef44d9d8fb32182ec41f76bcc15f731ccea28087e68fac7243d4c5f4dd43d8123705275bd5d6468b732689865d2566a37cf359e
-EBUILD routes-2.4.1.ebuild 1554 BLAKE2B 1bd301929542cf5594a12ebaad58e41fdb98699d91aba2b9c3d75d569f86e467dbaccb62e531df411dfe94ea763fc63f2ef83defc28f4d22a9e57d1aedd9a2b4 SHA512 8bc1d9a44fa2411276972e1627af73f46c1e23b02d66935d93c0148fea8be21c55db0c2a2ed022533c17c9f95e0dcedf0a6615df10756eb7767f3bd8128f2376
+EBUILD routes-2.4.1-r1.ebuild 1419 BLAKE2B 3bbef4b2393780480a558ee52addf1c8c443dde874dbf435262e01eb919bead429bd28fb5259a33b7b75e8d1a66a4c07bb86908b2a5184fb18e04b8b7087c5a0 SHA512 799b7d88549d84d7672ffd1af69cc0a88dafe7871e269755109ea72254d8bae73456bb67f2b4e268ddb466a6811d46c11591d320e256cd0283b3102bcab05e15
MISC metadata.xml 309 BLAKE2B 58e1b02098e87fe7303e9a6ce962897750493b957d3b30f78feb58b9cbec84b5fcf80acde66da35caa71989b628a75d232ea567e679f891fb4b81d1c49f61d06 SHA512 6daa7dcc2ae185c198c2630961d68c19498e98bce96ea3b1390a4c159fb591a89af796f2ac90e00994bda52c36138792797a38975c772d6fabce09cf0536722a
diff --git a/dev-python/routes/routes-2.4.1-r1.ebuild b/dev-python/routes/routes-2.4.1-r1.ebuild
index f43a59fba525..301a043a306d 100644
--- a/dev-python/routes/routes-2.4.1-r1.ebuild
+++ b/dev-python/routes/routes-2.4.1-r1.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc"
RDEPEND="
@@ -24,6 +24,9 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
"
+BDEPEND="
+ test? ( dev-python/webob[${PYTHON_USEDEP}] )"
+
distutils_enable_tests nose
distutils_enable_sphinx doc
diff --git a/dev-python/routes/routes-2.4.1.ebuild b/dev-python/routes/routes-2.4.1.ebuild
deleted file mode 100644
index fed9cbe23a3f..000000000000
--- a/dev-python/routes/routes-2.4.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
-HOMEPAGE="https://routes.readthedocs.io/en/latest/ https://pypi.org/project/Routes/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-# The testsuite appears to be held back by the author
-
-S="${WORKDIR}/${MY_P}"
-
-# https://github.com/bbangert/routes/issues/42 presents a patch
-# for the faulty docbuild converted to sed stmnts
-python_prepare_all() {
- # The default theme in sphinx switched to classic from shpinx-1.3.1
- if has_version ">=dev-python/sphinx-1.3.1"; then
- sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
- -i docs/conf.py || die
- else
- sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
- -i docs/conf.py || die
- fi
- sed -e "s:changes:changes\n todo:" \
- -i docs/index.rst || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}