summaryrefslogtreecommitdiff
path: root/dev-python/routes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/routes
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/Manifest5
-rw-r--r--dev-python/routes/routes-2.5.1-r2.ebuild51
-rw-r--r--dev-python/routes/routes-2.5.1.ebuild32
3 files changed, 54 insertions, 34 deletions
diff --git a/dev-python/routes/Manifest b/dev-python/routes/Manifest
index 5c3e557aaf56..1f0bc88339af 100644
--- a/dev-python/routes/Manifest
+++ b/dev-python/routes/Manifest
@@ -1,3 +1,4 @@
-DIST Routes-2.5.1.tar.gz 190905 BLAKE2B e1498d0a26c7ebb1ee423ad211221f648d5bab4d37effac8c34a5f5189558a62c3ab34780f98f6a1620a261efc6085afd54f0827ac0e7a80217de7ae2226580a SHA512 06ec9a8426ced86524096703de47e3da2fa08bd0ed8c962d451b4338966804245b5074077021fb58a5afcb63acd6dcffa05a89703b8b54841a69a4cdff12b755
-EBUILD routes-2.5.1.ebuild 824 BLAKE2B 4a91a08f3cbd77b124728a6583388d6b05db2fdf6be87780586bca9fc91e3be955bac3276ce1c8d0eb19d04ac5522c0933d43118c166670c280b7a9e53c07dcb SHA512 1ec411f3232c6c7dcd5b73d167aec0244d3918428689898b5d71e1b77d99bc7e3434353e19926776a830a2e0514029fe6ab3e43b80a1c4a2679dc567b303717d
+DIST routes-2.5.1-pytest.patch 229759 BLAKE2B 826a053e82b5cae9996c73c56948b24b8c508b33440c60aea62d8d2dfa6461a43377ee1748c8852dd8c2527b0666e9c4c64e38eeaea22fc67ee9291ddcdffb6d SHA512 e6dba07207bf52b931e2369ad32450ebbfbc26571502b9b827b6200f4ce7cfc7b784e4685f9f11472bed63b3711af10ed9833eda35003cc2010924eeeaae4235
+DIST routes-2.5.1.gh.tar.gz 198777 BLAKE2B ca3487af94677889c5249b501fc6dc07e155dd4a862df4f1c8391154598a343ee35b7e8be2b5200bdb234b606a837c471af806c9dc8aa39796b4f4db04bbb164 SHA512 939aebac11f5499ea5c4009e016c52b8b161e7d67c4a540cdbf456cb3db5aec80a4054e7bec9862aaaa02559b081b09cf699c6508e1ac9acffbc5706acd56f30
+EBUILD routes-2.5.1-r2.ebuild 1143 BLAKE2B 531cf918629dbc0ce9990f1b7b3a5249974bff79612748a9a70e42f2bd173e92d4a823c674ce9607295aaab631ac22cbb48bbc542ded4aba2772505b284fe3bd SHA512 664c47cb961e1b6098b80cab08940e1224239be63d94b4706297b49d6404d8f76e10fba22efb721143b40517ccba78959e8179da6cda3a099480a22bae6b73b6
MISC metadata.xml 334 BLAKE2B c7aa5fdd9bd9a77881619a3e7fb7332b28d9fb024de346707c7a966d7ba4e1ca10d0db6106cbb528cab879ce23a2e96adb18059d71122302b6a7b0e5c10a45a1 SHA512 43dd546f7b29a6be542e1286b40941854edd22d782d80bbed0861d94a57bb09f8c07a273f1c518315b585f77223fb440c229bc4863e554bb569518f0cf15e265
diff --git a/dev-python/routes/routes-2.5.1-r2.ebuild b/dev-python/routes/routes-2.5.1-r2.ebuild
new file mode 100644
index 000000000000..d03227f17e9f
--- /dev/null
+++ b/dev-python/routes/routes-2.5.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
+HOMEPAGE="
+ https://routes.readthedocs.io/en/latest/
+ https://github.com/bbangert/routes/
+ https://pypi.org/project/Routes/
+"
+SRC_URI="
+ https://github.com/bbangert/routes/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/bbangert/routes/pull/107.patch
+ -> ${P}-pytest.patch
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ia64 ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${DISTDIR}/${P}-pytest.patch"
+)
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # fix the version number
+ sed -i -e '/tag/d' setup.cfg || die
+ find tests -name '__init__.py' -delete || die
+}
diff --git a/dev-python/routes/routes-2.5.1.ebuild b/dev-python/routes/routes-2.5.1.ebuild
deleted file mode 100644
index ca648eda22eb..000000000000
--- a/dev-python/routes/routes-2.5.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
-HOMEPAGE="https://routes.readthedocs.io/en/latest/ https://pypi.org/project/Routes/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests nose