summaryrefslogtreecommitdiff
path: root/dev-python/routes/routes-2.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/routes/routes-2.4.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/routes/routes-2.4.1.ebuild')
-rw-r--r--dev-python/routes/routes-2.4.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/routes/routes-2.4.1.ebuild b/dev-python/routes/routes-2.4.1.ebuild
deleted file mode 100644
index 89a8441f1d91..000000000000
--- a/dev-python/routes/routes-2.4.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
-HOMEPAGE="https://routes.readthedocs.io/en/latest/ https://pypi.org/project/Routes/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-# The testsuite appears to be held back by the author
-
-S="${WORKDIR}/${MY_P}"
-
-# https://github.com/bbangert/routes/issues/42 presents a patch
-# for the faulty docbuild converted to sed stmnts
-python_prepare_all() {
- # The default theme in sphinx switched to classic from shpinx-1.3.1
- if has_version ">=dev-python/sphinx-1.3.1"; then
- sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
- -i docs/conf.py || die
- else
- sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
- -i docs/conf.py || die
- fi
- sed -e "s:changes:changes\n todo:" \
- -i docs/index.rst || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}