summaryrefslogtreecommitdiff
path: root/dev-python/rospkg/rospkg-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/rospkg/rospkg-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/rospkg/rospkg-9999.ebuild')
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index bf7619313e02..c59845d0d461 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
@@ -30,10 +30,13 @@ SLOT="0"
IUSE="test"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)