summaryrefslogtreecommitdiff
path: root/dev-python/rospkg/rospkg-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/rospkg/rospkg-1.3.0.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/rospkg/rospkg-1.3.0.ebuild')
-rw-r--r--dev-python/rospkg/rospkg-1.3.0.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/dev-python/rospkg/rospkg-1.3.0.ebuild b/dev-python/rospkg/rospkg-1.3.0.ebuild
index 9a43e2fb6d1e..fbd4db374f38 100644
--- a/dev-python/rospkg/rospkg-1.3.0.ebuild
+++ b/dev-python/rospkg/rospkg-1.3.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+
+PYTHON_COMPAT=( python3_{8..10} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -27,26 +27,16 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND} ${BDEPEND}
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)
"
PATCHES=( "${FILESDIR}/gentoo.patch" "${FILESDIR}/yaml_load.patch" )
-python_test() {
- nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
-}
+distutils_enable_tests nose