summaryrefslogtreecommitdiff
path: root/dev-python/ropemode/ropemode-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/ropemode/ropemode-0.5.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/ropemode/ropemode-0.5.ebuild')
-rw-r--r--dev-python/ropemode/ropemode-0.5.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/ropemode/ropemode-0.5.ebuild b/dev-python/ropemode/ropemode-0.5.ebuild
index 2c3fb327d4cc..eb540c46a0a4 100644
--- a/dev-python/ropemode/ropemode-0.5.ebuild
+++ b/dev-python/ropemode/ropemode-0.5.ebuild
@@ -3,11 +3,11 @@
EAPI=7
-# Currently (2020-03-23) rope is blocking
-# support for python 3.8.
+# Currently (2020-11-04) rope is blocking
+# support for python 3.9.
# For details see
-# https://github.com/python-rope/rope/pull/285
-PYTHON_COMPAT=( python3_{6,7} )
+# https://github.com/python-rope/rope/issues/299
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
@@ -20,11 +20,8 @@ SRC_URI="https://github.com/python-rope/ropemode/archive/${PV}.tar.gz -> ${P}.ta
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="dev-python/rope[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
"${PYTHON}" ropemodetest.py || die "tests failed with ${EPYTHON}"