summaryrefslogtreecommitdiff
path: root/dev-python/rope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 10:15:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 10:15:54 +0000
commiteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (patch)
treebbe526e2a2c1fd2fd7ee20d62b99c7ac30476aff /dev-python/rope
parent6471b382a951b256ffa1b8ea3e6e7d7f5b189281 (diff)
gentoo auto-resync : 06:11:2023 - 10:15:54
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest2
-rw-r--r--dev-python/rope/rope-1.11.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 0faae4375179..cfe799dd1f4d 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,3 +1,5 @@
DIST rope-1.10.0.tar.gz 299732 BLAKE2B bc8b276eb1e69730536d947ffb167bef3dd2dfa453c1834349e78ceb1dda56aa51cff556687bbebaca4e0cad1055da0db5294e029be59d525bc170564bfe3870 SHA512 3a8c31a89f14a78f9a0931e87e21b0a617891382e879b50a6fa846ad576ad6bf62f81ccd8c00bd237b77807832a760120256655ac4d6a73626c0b0f1b5c61100
+DIST rope-1.11.0.tar.gz 287210 BLAKE2B 64aebaf2a52f84d6e92ba0ccbaf5421b46a52de92675c03922167e2d363d5916675856795b0adaa70d54d4e8249870348ee002648244537dc1acb123fc8c6350 SHA512 e5c382325a900c1b5870aae0b7ef60528da6c73a27834b557f5245e6a6bf3412451c730cac0d5fb12f1a668dd7a8d8d0c814826babce59eb00198cd6706c016d
EBUILD rope-1.10.0.ebuild 895 BLAKE2B 14a96b3d534e164215d7c4b7e4c7167bbca9d4f71b2445a3db79f847b58e0958293283acfc966e1c24b7f25c8018f91e331c11cdbfc7908b00ed80b49be7f3d0 SHA512 ff3123c654d1692d4924e04c6342121980c65c76eacc307ea04d84a0a3efe1a1e0cb78858cdc596c5909cbcd7add87ef8630b2b6cbad7941a4405d456e90d5b3
+EBUILD rope-1.11.0.ebuild 897 BLAKE2B c2849fda89cab1f896394001162169ddb20e4604bc7a664ec5d40932b9e64a6840a4b52d16f6b7909699a61f4e80f49be4ced08b23ddb9025cf7dec7beae5f89 SHA512 bb8c5d122a9a971d81ec5a8201a6a338a595f161669a1f5f4e3f760c208d0cd1afb9bc60a01eb83c6474395237541e3cf730629b28900900214f02b715cb157f
MISC metadata.xml 452 BLAKE2B 6bee424d801bad8728f10ec3a1618e3a48776a7b0af2a04efafd07e6ae5ac8e0b88253ebc35e457c791e820f8c3b1dabde73aabbfd3636cac5e169e8aca75aa7 SHA512 4f88e1157e4838f321b6f208ba6b89fbf2b7a72ea6e038cdd6cf3e9e211c2788dda137e3adf76072c1d52026c554750193d9938054670dd995a91db24ea8da76
diff --git a/dev-python/rope/rope-1.11.0.ebuild b/dev-python/rope/rope-1.11.0.ebuild
new file mode 100644
index 000000000000..c2536d79323e
--- /dev/null
+++ b/dev-python/rope/rope-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)