summaryrefslogtreecommitdiff
path: root/dev-python/rope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rope
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest6
-rw-r--r--dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch35
-rw-r--r--dev-python/rope/metadata.xml16
-rw-r--r--dev-python/rope/rope-0.10.3.ebuild44
-rw-r--r--dev-python/rope/rope-0.10.7.ebuild46
5 files changed, 147 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
new file mode 100644
index 000000000000..ab2c97a108a1
--- /dev/null
+++ b/dev-python/rope/Manifest
@@ -0,0 +1,6 @@
+AUX rope-0.10.3-doc-syntax-errors.patch 1207 BLAKE2B 2eb81ffc507c532feff64a09b04e9c098e0d52f702048b2e69abf53b0099454edcb82d866b8b7e83a77e493495a15e3e944f376aa2d1a0e3ddeffebb2435745e SHA512 6bf617e20ef8810496b92cb5e55240622ea7285c435b090254cd9211a29f0c8d103322ed772424cdaeb528dabe1a606adea95647480fed9609e71c29584faaf3
+DIST rope-0.10.3.tar.gz 226123 BLAKE2B e7f29545280a8615486547a8c29f44894d3c84659af9cb87ac596238a829f3a21a778e92ffe7e260cf27b52639983be1b3d62b38a727ce31a9c7ec225abc76ad SHA512 1d868aeebd086c3fc199316a71e61a8c46c76d85176557842051bb8f51d090f316df6bb84f766db5a46dc164d3e471eb90465805a102e46acb34e39b2b0ce8b4
+DIST rope-0.10.7.tar.gz 244089 BLAKE2B aebc1eaa3715aa4f2423490790f53040ad256fca35b3ad7b516e6b1f0af051b79f812f7b701ff5ac2414dbf2d1cba319da0f4cf241041329c0c750ae63e0ec33 SHA512 80343b8b7af883afbd04734b0fe4dbdab114301234654cbd95b3ae8be8dff40878105b7647209f5e899b981ab6a7ecb987d9bdf942b32ed083c745128c22ef95
+EBUILD rope-0.10.3.ebuild 1033 BLAKE2B a545fd4b68149939f9d6e07a207d16f4a9ed7934a0a4e4d8a08d3bd70cdae4a5fcedc8430dd6db22f7d474c7c233df837af22f771b2931c8f2b70d1010b22be4 SHA512 78312c709aa2298027ff4a8340b5fc010d742233db9acb1715eede323c85448e96b4f65f7d506bff6374b9437fdd8fae3c8dd85264f78c4922c5ce313fcf911f
+EBUILD rope-0.10.7.ebuild 1132 BLAKE2B ada08d997e0036e07cc20e75ae9d722b40abf253f46d08388c0712abf3591af4b6fa845fbc9f1e3cbf3f912aadc4257b1dc6f302fd2bfd6b9eddb276ef62490c SHA512 18dc44202581a659d3972a13a967f12ccbaa5b4238ca812e088b10719b014d75014140cc12a69969d68cada7c51e53eaa1995d993cd28875802a22024d790c34
+MISC metadata.xml 517 BLAKE2B 165eea4dc0b2ee1244b9b94f3763c90692c6483d4c09b6535197b34ace789d364c2b63de1dc9d50645ec01cc2975c6f20a95d7756c2bac78a40733e343b7968c SHA512 6289b55677d1e26372017042042229865bad64a396952c21a7d5a1f25322c2ccfed11c0a9ea0c0896573dd1f04dc3263dc3eb28ff7b0b804c2bddf231e924630
diff --git a/dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch b/dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch
new file mode 100644
index 000000000000..f219e1bb02ad
--- /dev/null
+++ b/dev-python/rope/files/rope-0.10.3-doc-syntax-errors.patch
@@ -0,0 +1,35 @@
+# Fix syntax errors in doc files
+diff --git a/docs/contributing.rst b/docs/contributing.rst
+index c6cb8a8..9efc3cc 100644
+--- a/docs/contributing.rst
++++ b/docs/contributing.rst
+@@ -45,7 +45,7 @@ about them, don't hesitate to discuss it in the mailing list.
+ Getting Ready For Python 3.0
+ ----------------------------
+
+-Checkout http://bitbucket.org/agr/rope_py3k Mercurial_ repository.
++Checkout http://bitbucket.org/agr/rope_py3k Mercurial repository.
+ Contributions are welcome.
+
+ Write Plugins For Other IDEs
+@@ -79,7 +79,7 @@ Source Repository
+ =================
+
+ Rope uses GitHub_. The repository exists at
+-`https://github.com/python-rope/rope`_.
++`https://github.com/python-rope/rope`.
+
+
+ Submitting patches
+diff --git a/docs/library.rst b/docs/library.rst
+index 390b9c8..ee918bc 100644
+--- a/docs/library.rst
++++ b/docs/library.rst
+@@ -72,7 +72,7 @@ In rope, files and folders in a project are accessed through
+ ``Change``\s (we'll talk about them later) use resources.
+
+ There are two options for creating a ``Resource`` for a path in a project.
+-The first approach uses the `Project.get_resource()`_ method.
++The first approach uses the `Project.get_resource()` method.
+
+ .. code-block:: python
diff --git a/dev-python/rope/metadata.xml b/dev-python/rope/metadata.xml
new file mode 100644
index 000000000000..0070618315a2
--- /dev/null
+++ b/dev-python/rope/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Rope is a python refactoring library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rope</remote-id>
+ <remote-id type="sourceforge">rope</remote-id>
+ <remote-id type="github">python-rope/rope</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rope/rope-0.10.3.ebuild b/dev-python/rope/rope-0.10.3.ebuild
new file mode 100644
index 000000000000..520fe2fecc00
--- /dev/null
+++ b/dev-python/rope/rope-0.10.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}/${P}-doc-syntax-errors.patch" )
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/rope/rope-0.10.7.ebuild b/dev-python/rope/rope-0.10.7.ebuild
new file mode 100644
index 000000000000..970ce8c70ce1
--- /dev/null
+++ b/dev-python/rope/rope-0.10.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="!dev-python/rope_py3k"
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.10.3-doc-syntax-errors.patch" )
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}