summaryrefslogtreecommitdiff
path: root/dev-python/rope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
commit66520d3148e31806a52cf7df5b8d91d5cd431670 (patch)
tree15d0c80d9ee1b1e2a454a9930a03e3d3b7c6cc61 /dev-python/rope
parent0e82736d0df44565875b055019ded1be0ac5c319 (diff)
gentoo auto-resync : 17:01:2023 - 07:14:19
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest2
-rw-r--r--dev-python/rope/rope-1.7.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index eaced481eaaa..adb5f34e3952 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,3 +1,5 @@
DIST rope-1.6.0.tar.gz 289325 BLAKE2B fc7fc37a93f6d011f7e5eab5d2a28e3eab1767839cba4bce2b665c7972d6485eb3693e5977abfd36025415bc898fb4985affb7ac757c8457840a5de3946df77d SHA512 f610eb71c20533907aeea86c3ec5101401cf8136aba4221b2d64db3b0db16d4d7d1ec081c6d4929d6534ed51d4c01761af8d2ffddb6b69b4a9cc4921d240d745
+DIST rope-1.7.0.tar.gz 295362 BLAKE2B a81d6600441cf9dfe12be0a15113988ac8ec3dcd00c593085b9d749001b0785a5bceedc0fa8bbaeaaeb0142d623a432ef7d6e24874fab7a37179f131a26e6a6c SHA512 13cc3a2041c58c142892d1c9e5105ecdaa672e012364a5d4ccf82dbf5110fe0b6f0362b3a0309e9e6b72ab1d267dfc58eae8f3af3a8756f0356a6aff06c09abd
EBUILD rope-1.6.0.ebuild 934 BLAKE2B 0d52baba8975ce17d01b82461d3301c81e33e296bad57f8526aa4cdf4847aef36c9e7e463b7d069d1a7029fe7c6d1c2bc7713981bcc7b97683eee69261ba4a45 SHA512 928868be85b2608b84479c5c4a4879d857310b263ac708629a7e93d75968dd4349016569ace3e8dd27c46d179f1a17341057990f36113b471bde75dcbd006da3
+EBUILD rope-1.7.0.ebuild 936 BLAKE2B 1700bce1ea6304ef383aaf14cfd32e871ff29cd9c8af756c4b149cdade74bd1443f57044192c3b5b852d172891a77da11a8d83e580d79ce8220ac8f5c2fc954f SHA512 8603262b600681d813270fcdf688c7c949d6aea0e96f8063d475575cb5cd730f90b3de43e41b65cdd48f26570cb51f7e2e68f4f064ae338bf62d7c9a2778ba29
MISC metadata.xml 452 BLAKE2B 6bee424d801bad8728f10ec3a1618e3a48776a7b0af2a04efafd07e6ae5ac8e0b88253ebc35e457c791e820f8c3b1dabde73aabbfd3636cac5e169e8aca75aa7 SHA512 4f88e1157e4838f321b6f208ba6b89fbf2b7a72ea6e038cdd6cf3e9e211c2788dda137e3adf76072c1d52026c554750193d9938054670dd995a91db24ea8da76
diff --git a/dev-python/rope/rope-1.7.0.ebuild b/dev-python/rope/rope-1.7.0.ebuild
new file mode 100644
index 000000000000..827ea89bc22c
--- /dev/null
+++ b/dev-python/rope/rope-1.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)