summaryrefslogtreecommitdiff
path: root/dev-python/rope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/rope
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest2
-rw-r--r--dev-python/rope/rope-0.16.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 252ccd46262a..89eb0a7b20d9 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,4 +1,6 @@
AUX rope-0.10.3-doc-syntax-errors.patch 1207 BLAKE2B 2eb81ffc507c532feff64a09b04e9c098e0d52f702048b2e69abf53b0099454edcb82d866b8b7e83a77e493495a15e3e944f376aa2d1a0e3ddeffebb2435745e SHA512 6bf617e20ef8810496b92cb5e55240622ea7285c435b090254cd9211a29f0c8d103322ed772424cdaeb528dabe1a606adea95647480fed9609e71c29584faaf3
DIST rope-0.10.7.tar.gz 244089 BLAKE2B aebc1eaa3715aa4f2423490790f53040ad256fca35b3ad7b516e6b1f0af051b79f812f7b701ff5ac2414dbf2d1cba319da0f4cf241041329c0c750ae63e0ec33 SHA512 80343b8b7af883afbd04734b0fe4dbdab114301234654cbd95b3ae8be8dff40878105b7647209f5e899b981ab6a7ecb987d9bdf942b32ed083c745128c22ef95
+DIST rope-0.16.0.tar.gz 243304 BLAKE2B 2c41572687ef245eb20abfccebcc9f12ecaa177be313cec59c85be5102b7358566570730a7140f952b0a1c515b479c3d21740d32d4678e65c4c572acf86f4e27 SHA512 33ba57b246337e413126309a521c54e861899b03fd250e148b97d9789cddf6eceab36609ea6e36e84ad1ac514bc3363f4937b01bcb96b6103c2a33bec1d4fb75
EBUILD rope-0.10.7.ebuild 1113 BLAKE2B b2604b27be6546a38eaff0afedc8ba2cc02fbfc25037374be85bd5c0660b02e2d594c9f7eeaeaa35b3045c7b1bbadedfba9f8a2e7c2ac0a552c8037155a420b8 SHA512 9cb3ab0f5d1695bd1c7dbf4bb85c7b14c25f587693e9e75f19f6c54333704185f982e43155446fa472cb5b51dbaa649f28ecca201b110869fc0ee4ab99eb0e44
+EBUILD rope-0.16.0.ebuild 982 BLAKE2B f4cb03afcfdb72051ff4f7cf481f995cb223f795c9e361b229639c00b587e7ceaa529da59bf47786bdac0c4b6f55049069dc70a9a78bb79485c611ebfbac2137 SHA512 d4b1107782253fd0ead95fdb3ddf709b5efc844b1e86154f2bf300a13261ce20b6ba9634f67d8ed17b5c861719ad8edfdb984e2a7144f7a8029a275171ca90dd
MISC metadata.xml 517 BLAKE2B 165eea4dc0b2ee1244b9b94f3763c90692c6483d4c09b6535197b34ace789d364c2b63de1dc9d50645ec01cc2975c6f20a95d7756c2bac78a40733e343b7968c SHA512 6289b55677d1e26372017042042229865bad64a396952c21a7d5a1f25322c2ccfed11c0a9ea0c0896573dd1f04dc3263dc3eb28ff7b0b804c2bddf231e924630
diff --git a/dev-python/rope/rope-0.16.0.ebuild b/dev-python/rope/rope-0.16.0.ebuild
new file mode 100644
index 000000000000..a60999bb3c8d
--- /dev/null
+++ b/dev-python/rope/rope-0.16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}