summaryrefslogtreecommitdiff
path: root/dev-python/rope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/rope
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest3
-rw-r--r--dev-python/rope/rope-0.22.0-r1.ebuild42
-rw-r--r--dev-python/rope/rope-0.23.0.ebuild42
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 2580233fb4ee..840c41f0d8fb 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,3 +1,6 @@
DIST rope-0.22.0.tar.gz 260138 BLAKE2B 11aff47af50225d66ade44a63a2c747bc11f0adcec1abed2dff71466f088f1460b3eec541db326af545f89907eb9d4f518c24ec8a445ca07b3116573883123ec SHA512 ead82eba834890d90a6972cc432d153b977a123588621712b50decf1f1bfff03cd411e3615dff63a5272cf4a46b32791ea625f30e3dfdf9d1969081a99544396
+DIST rope-0.23.0.tar.gz 260990 BLAKE2B 34064f45f72d6c9c5613eb5d9480dde25aeb5426ab3ea9b56e7ba5e4da1d9930735bd87757e3e885d4504ddcb24b23aa96b0d5be7c23ca4969201aedbaa3aa24 SHA512 1ab0a36c792fdc4d0fd1e554deec0fb6d1e877d91164fb8ee2e5f99240087f8a8d4608d1975be100bca87be0321d672b91579cf36795acffc742aa021cdf5e1b
+EBUILD rope-0.22.0-r1.ebuild 902 BLAKE2B db31a48188488d8a7cfe99cecaef0a7913bb789e42d15cb8bea78085793d31a527a2b0f7af9a8eb9e0467cda75e957de0b240801bd6f8ec2d912149d43f8be5b SHA512 12f87e02cf408a0cae13a0a3fe2c8d048325887687564382478e9c9bb9c92efac76053ec4ede891e8528044313bf02b611dc15c5da5e822ba91c5e76990840e0
EBUILD rope-0.22.0.ebuild 990 BLAKE2B a74b53e9e04cc39d8d846c41412a1ddf72f7650687aca675dcae1df48330ac7bfe7bdefd212c8a2621565052eb256e687501a692d505c78f369f419b88d90e88 SHA512 958473927b7a9426efa2a3360fb7d6c0418416fc45478ce153ed21c0b8e3f24ac206664027af558bcc1b7b4fdb21b64396863a05775e71311fdc30512ddbe96a
+EBUILD rope-0.23.0.ebuild 902 BLAKE2B db31a48188488d8a7cfe99cecaef0a7913bb789e42d15cb8bea78085793d31a527a2b0f7af9a8eb9e0467cda75e957de0b240801bd6f8ec2d912149d43f8be5b SHA512 12f87e02cf408a0cae13a0a3fe2c8d048325887687564382478e9c9bb9c92efac76053ec4ede891e8528044313bf02b611dc15c5da5e822ba91c5e76990840e0
MISC metadata.xml 452 BLAKE2B 6bee424d801bad8728f10ec3a1618e3a48776a7b0af2a04efafd07e6ae5ac8e0b88253ebc35e457c791e820f8c3b1dabde73aabbfd3636cac5e169e8aca75aa7 SHA512 4f88e1157e4838f321b6f208ba6b89fbf2b7a72ea6e038cdd6cf3e9e211c2788dda137e3adf76072c1d52026c554750193d9938054670dd995a91db24ea8da76
diff --git a/dev-python/rope/rope-0.22.0-r1.ebuild b/dev-python/rope/rope-0.22.0-r1.ebuild
new file mode 100644
index 000000000000..f461efcc5f5f
--- /dev/null
+++ b/dev-python/rope/rope-0.22.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/rope/rope-0.23.0.ebuild b/dev-python/rope/rope-0.23.0.ebuild
new file mode 100644
index 000000000000..f461efcc5f5f
--- /dev/null
+++ b/dev-python/rope/rope-0.23.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}