summaryrefslogtreecommitdiff
path: root/dev-python/root_numpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/root_numpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/root_numpy')
-rw-r--r--dev-python/root_numpy/Manifest5
-rw-r--r--dev-python/root_numpy/metadata.xml21
-rw-r--r--dev-python/root_numpy/root_numpy-4.4.0.ebuild35
-rw-r--r--dev-python/root_numpy/root_numpy-4.7.3.ebuild35
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/root_numpy/Manifest b/dev-python/root_numpy/Manifest
new file mode 100644
index 000000000000..3ab0d5ec7d54
--- /dev/null
+++ b/dev-python/root_numpy/Manifest
@@ -0,0 +1,5 @@
+DIST root_numpy-4.4.0.tar.gz 441522 BLAKE2B af3b0b08e80e7cba57730cdb32719ad56be914b5329d953693b898f2bb30c19b3bfa7bb4594e7fed819b08a3ba6894580e38d03f9520ecffab7a67daa17898be SHA512 24afa043e4bdaa74412c36ff90ee8c1fc411801d9dc394ab5036035924910a7f4f304c5c90f4c5f389aaee9dda07b0b7e25566e68c4da424f1b4d59e6184f5b2
+DIST root_numpy-4.7.3.tar.gz 522432 BLAKE2B 9aab3090c894d8917218a68d83269c0f426ee4e7f81628081e9e710c4239bba5e8f88dcb1d91156cf02c7c36b1ee5d03cdd0c3931ca6e2f3eee6c78201386705 SHA512 7c2684ac0e4e68676304e2a72c7169e0299cfea5b4b63f2525a422974ca83f9c9b4f9f11d992acef7d8565cda7f7a85bd13621513cd7c47f1887aaa0cc46d6e7
+EBUILD root_numpy-4.4.0.ebuild 792 BLAKE2B d98e85a258b45ccb4b8d6a6f551c25a3e05ee176ca845f7baca9e8ac68698b2c5973ab53fd3129272fe168d2848a846ae01040fe14a2aa121b60447538bca538 SHA512 468baef03b8c334c772e34c88501457357a5f16bbed3db5b3122057565d1a80503a21ee435a9ea82ceb0e4cf9961b5f8e62dfcfb72e4adf06d3f48778d0b1c52
+EBUILD root_numpy-4.7.3.ebuild 800 BLAKE2B cf67579ded3ba4e8028dfc7afbe338bfbfcd13e386a60c61a07a7842a4cd18534fda4f55d947d593d512cc4e639effe0592c4ec2852259d0375f54593ff7245a SHA512 5fc36155c103c8ab6b8051c1d587e77780f4efcd2613aab2a76e4698eeed2e57be42ca3728d1838d87bd249d0d17625b3484af4774afe7bcf82e5b3a0b37772a
+MISC metadata.xml 898 BLAKE2B f9b4c5ea3d9d901488196239d8076a31acce527480fe3775d1c83545b3436c3c78c21032b7e25d4f8ebe8634dd6c906fa959abe9e68a2b92705aa9864a5afcf3 SHA512 f013cc8dfb3cb8887bb87195d69c765c39262b4d71fbf92bb46a39915b609469a351efc31e130b313bd8379b2a3c41b5927bcd86be5cad8933acf282fad20cb7
diff --git a/dev-python/root_numpy/metadata.xml b/dev-python/root_numpy/metadata.xml
new file mode 100644
index 000000000000..07c071353ab4
--- /dev/null
+++ b/dev-python/root_numpy/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ root_numpy is a Python extension for converting ROOT TTrees into
+ NumPy recarrays or structured arrays. With the core internals
+ written in C++, root_numpy can efficiently handle large amounts of
+ data (limited only by the available memory).
+ Now that your ROOT data is in NumPy form, you can make use of the many
+ powerful scientific Python packages or perform quick exploratory data
+ analysis in interactive environments like IPython.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">root_numpy</remote-id>
+ <remote-id type="github">rootpy/root_numpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/root_numpy/root_numpy-4.4.0.ebuild b/dev-python/root_numpy/root_numpy-4.4.0.ebuild
new file mode 100644
index 000000000000..c472f85d8226
--- /dev/null
+++ b/dev-python/root_numpy/root_numpy-4.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface between ROOT and numpy"
+HOMEPAGE="https://github.com/rootpy/root_numpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-physics/root[python,${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( tutorial/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/root_numpy/root_numpy-4.7.3.ebuild b/dev-python/root_numpy/root_numpy-4.7.3.ebuild
new file mode 100644
index 000000000000..7561d10b0391
--- /dev/null
+++ b/dev-python/root_numpy/root_numpy-4.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface between ROOT and numpy"
+HOMEPAGE="https://github.com/rootpy/root_numpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-physics/root:=[python,${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( tutorial/. )
+ distutils-r1_python_install_all
+}