summaryrefslogtreecommitdiff
path: root/dev-python/roman/roman-4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 21:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 21:10:11 +0100
commita20b8556104c163a81183ff983af8123e40f16c5 (patch)
treefc59d7e55cf6c354a7a395587dcfbed577557a84 /dev-python/roman/roman-4.1.ebuild
parentf3a881e4cb31d574a107320b2f04e2d1f0ddf551 (diff)
gentoo auto-resync : 26:05:2023 - 21:10:11
Diffstat (limited to 'dev-python/roman/roman-4.1.ebuild')
-rw-r--r--dev-python/roman/roman-4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/roman/roman-4.1.ebuild b/dev-python/roman/roman-4.1.ebuild
new file mode 100644
index 000000000000..6a45d27c7c18
--- /dev/null
+++ b/dev-python/roman/roman-4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An Integer to Roman numerals converter"
+HOMEPAGE="
+ https://pypi.org/project/roman/
+ https://github.com/zopefoundation/roman
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ mv "${S}/src/tests.py" . || die "moving test file failed"
+ distutils-r1_python_prepare_all
+}