summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/rich
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest3
-rw-r--r--dev-python/rich/metadata.xml13
-rw-r--r--dev-python/rich/rich-9.11.1.ebuild28
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
new file mode 100644
index 000000000000..f1e52ea08851
--- /dev/null
+++ b/dev-python/rich/Manifest
@@ -0,0 +1,3 @@
+DIST rich-9.11.1.tar.gz 14050070 BLAKE2B 7dcae32743bfcbbab0af6896f72e865d2a72ab66545168544d065145cf10a2aab4785454e547f011219a85a8aa762f1ed5ebef2b9fb7f44225a2f776835b643d SHA512 2139cb6602d930e9bf1479456a8e6cee812237fb64073db3f23fd8eab64c1c2b3a83c6292f1f90652791100a93961d8ec8036e5d819f1e23159b6b9a75cd1f6c
+EBUILD rich-9.11.1.ebuild 783 BLAKE2B c487ec61fd8fc42065954d2eff2e5e38dd2faf8ce54007e8129f9e83cae675ec672b51cfb6f5fb647c33c1920b239950274f0a0ee4a23dc00e2a57f59bb74f42 SHA512 b0c2fc1d5926af38d2a1448aaf6c63f22a873430642b1e48919ca8f19d1cda60f0122b0f4346efb0e5cc3f549b536a8895a5fcdf140acc7b274ec9181c709e18
+MISC metadata.xml 392 BLAKE2B ddb87719a768fbfa9efb493e82b4bf7401fc60782e24a0387e0ed50eacbcd9069beb7f3f75fdff28a906bcbcd597312bc79a2b252fe44487d16289ba81520f6c SHA512 3676c47be47b729d8d794e0359cf1ba7dc8b5c9318520474c323e71962dfc9a013f7a56f69147b9bab9d0c8334c57384fef3ed2adb7177677b8cc9033ebc6418
diff --git a/dev-python/rich/metadata.xml b/dev-python/rich/metadata.xml
new file mode 100644
index 000000000000..ee58016921d5
--- /dev/null
+++ b/dev-python/rich/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">rich</remote-id>
+ <remote-id type="github">willmcgugan/rich</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rich/rich-9.11.1.ebuild b/dev-python/rich/rich-9.11.1.ebuild
new file mode 100644
index 000000000000..a62e88778e09
--- /dev/null
+++ b/dev-python/rich/rich-9.11.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}